• HDU 1013 Digital Roots(to_string的具体运用)


    传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1013

    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 90108    Accepted Submission(s): 28027


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     
    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     
    Output
    For each integer in the input, output its digital root on a separate line of the output.
     
    Sample Input
    24
    39
    0
     
    Sample Output
    6
    3
     
     
    分析:
    这个题有点坑,不能用int输入,也不能用long long 输入
    得用字符串
    应该是输入太大了
    有点编译器可能无法识别to_string,需要下载补丁。。。
    比如codeblocks
    code:
    #include<bits/stdc++.h>
    #include<string.h>
    using namespace std;
    typedef long long LL;
    int main()
    {
        string s;
        LL sum;
        while(cin>>s)
        {
            if(s=="0")
                break;
            while(s.size()>1)//当size==1的时候,就是答案
            {
                sum=0;
                for(int i=0;i<s.size();i++)
                {
                    sum+=(s[i]-'0');//累加
                }
                s=to_string(sum);//转化成字符串
            }
            cout<<s<<endl;
        }
        return 0;
    }
  • 相关阅读:
    python 连接ubuntu xampp mysql
    [解决] win7能上网,ubuntu14.04不行
    ubuntu14.04 安装 pyv8
    QT_QMAKE_EXECUTABLE reported QT_INSTALL_LIBS as /usr/lib/i386-linux-gnu but ...
    网站运营思想
    织梦直接往数据库写入数据
    [xunsearch] 在thinkphp中使用xunsearch
    [xampp] phpmyadmin 设置登录密码
    [centos6.5] 把xampp的htdocs改为其他目录
    [ubuntu] service apache2 restart [fail]
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9313284.html
Copyright © 2020-2023  润新知