• poj2135(简单的最小费用流问题)


    题目链接:http://poj.org/problem?id=2135


    Farm Tour
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10862   Accepted: 4024

    Description

    When FJ's friends visit him on the farm, he likes to show them around. His farm comprises N (1 <= N <= 1000) fields numbered 1..N, the first of which contains his house and the Nth of which contains the big barn. A total M (1 <= M <= 10000) paths that connect the fields in various ways. Each path connects two different fields and has a nonzero length smaller than 35,000. 

    To show off his farm in the best way, he walks a tour that starts at his house, potentially travels through some fields, and ends at the barn. Later, he returns (potentially through some fields) back to his house again. 

    He wants his tour to be as short as possible, however he doesn't want to walk on any given path more than once. Calculate the shortest tour possible. FJ is sure that some tour exists for any given farm.

    Input

    * Line 1: Two space-separated integers: N and M. 

    * Lines 2..M+1: Three space-separated integers that define a path: The starting field, the end field, and the path's length. 

    Output

    A single line containing the length of the shortest tour. 

    Sample Input

    4 5
    1 2 1
    2 3 1
    3 4 1
    1 3 2
    2 4 2

    Sample Output

    6
    

    Source

    [Submit]   [Go Back]   [Status]   [Discuss]


    将问题转换为从1号节点到N号节点的两条没有公共边的路径就可以。

    这样就转换成了。求流量为2的最小费用流。


    code:

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<vector>
    #include<queue>
    using namespace std;
    const int MAXV=10010;
    const int MAXM=10010;
    const int INF=1<<30;
    typedef pair<int,int> P;
    struct edge{int to,cap,cost,rev;};
    int V;
    vector<edge> G[MAXV];
    int h[MAXV];
    int dist[MAXV];
    int prevv[MAXV],preve[MAXV];
    void add_edge(int from,int to,int cap,int cost)
    {
        G[from].push_back((edge){to,cap,cost,G[to].size()});
        G[to].push_back((edge){from,0,-cost,G[from].size()-1});
    }
    int min_cost_flow(int s,int t,int f)
    {
        int res=0;
        fill(h,h+V,0);
        while(f>0)
        {
            priority_queue<P,vector<P>,greater<P> >que;
            fill(dist,dist+V,INF);
            dist[s]=0;
            que.push(P(0,s));
            while(!que.empty())
            {
                P p=que.top();
                que.pop();
                int v=p.second;
                if(dist[v]<p.first)
                {
                    continue;
                }
                for(int i=0;i<G[v].size();i++)
                {
                    edge &e=G[v][i];
                    if(e.cap>0&&dist[e.to]>dist[v]+e.cost+h[v]-h[e.to])
                    {
                        dist[e.to]=dist[v]+e.cost+h[v]-h[e.to];
                        prevv[e.to]=v;
                        preve[e.to]=i;
                        que.push(P(dist[e.to],e.to));
                    }
                }
            }
            if(dist[t]==INF)
            {
                return -1;
            }
            for(int v=0;v<V;v++) h[v]+=dist[v];
            int d=f;
            for(int v=t;v!=s;v=prevv[v])
            {
                d=min(d,G[prevv[v]][preve[v]].cap);
            }
            f-=d;
            res+=d*h[t];
            for(int v=t;v!=s;v=prevv[v])
            {
                edge &e=G[prevv[v]][preve[v]];
                e.cap-=d;
                G[v][e.rev].cap+=d;
            }
        }
        return res;
    }
    int N,M;
    int a[MAXM],b[MAXM],c[MAXM];
    void solve()
    {
        int s=0,t=N-1;
        V=N;
        for(int i=0;i<M;i++)
        {
            add_edge(a[i]-1,b[i]-1,1,c[i]);
            add_edge(b[i]-1,a[i]-1,1,c[i]);
        }
        cout<<min_cost_flow(s,t,2)<<endl;
    }
    int main()
    {
        while(cin>>N>>M)
        {
            for(int i=0;i<M;i++)
            {
                scanf("%d%d%d",&a[i],&b[i],&c[i]);
            }
            solve();
        }
        return 0;
    }
    



  • 相关阅读:
    详解 Android Activity 生命周期
    设计模式:装饰者模式
    析构函数virtual与非virtual区别 [转]
    详解 常量指针和指针常量
    [转]Python yield 使用浅析
    python 列表 总结
    [转]关于Python中的yield
    详解c++指针的指针和指针的引用
    转:Ogre源码剖析
    转:Ogre源码剖析1
  • 原文地址:https://www.cnblogs.com/yfceshi/p/7091175.html
Copyright © 2020-2023  润新知