• 1.2.7 IBM Minus One 43.37%(504,1162)


    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1162 Accepted Submission(s): 504
     
    Problem Description
    You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

    After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

    Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.
     
    Input
    The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.
     
    Output
    For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

    Print a blank line after each test case.我去,这里每行后都有空行……题还是要读仔细才行。
     
    Sample Input
    2
    HAL
    SWERC
     
    Sample Output
    String #1
    IBM
    
    String #2
    TXFSD
     
     
    Source
    Southwestern Europe 1997, Practice
     
    Recommend
    Ignatius.L
    View Code
    #include<iostream>
    #include<iomanip>
    using namespace std;

    int main()
    {
    int n,i,j;
    char a,c[50],*p;
    cin>>n;
    a=getchar();
    for(i=0;i<n;i++){
    cin.getline(c,50);
    p=c;
    while(*p!='\0'){
    if(*p!='Z')
    (*p)++;
    else
    *p='A';
    p++;
    }
    cout<<"String #"<<i+1<<endl<<c<<endl<<endl;
    }
    system("pause");
    return 0;
    }
  • 相关阅读:
    jQuery$命名冲突问题解决方法
    微信小程序开发工具 ubuntu linux版本
    阿里云Https通配符证书购买
    vs2017安装
    规范与标准
    Jvm远程监控
    Bash笔记
    Html5前端笔记
    Php7 开发笔记
    webpack笔记
  • 原文地址:https://www.cnblogs.com/yangshuo/p/2360938.html
Copyright © 2020-2023  润新知