• Poj1131-Octal Fractions


    Octal Fractions
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 6669   Accepted: 3641

    Description

    Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.953125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point. 

    Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals.

    Input

    The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k.

    Output

    Your output will consist of a sequence of lines of the form 

    0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

    where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

    Sample Input

    0.75
    0.0001
    0.01234567

    Sample Output

    0.75 [8] = 0.953125 [10]
    0.0001 [8] = 0.000244140625 [10]
    0.01234567 [8] = 0.020408093929290771484375 [10]

    用java的大数,感觉挺好

    import java.util.*;
    import java.io.*;
    import java.math.*;
    import java.text.*;
    public class Main {
        public static void main(String[] args){
            Scanner sc = new Scanner(new BufferedInputStream(System.in));   ///用BufferedInputStream据说能快点
            BigDecimal ans, t, tmp;
            while(sc.hasNext()){
                String st = sc.nextLine();     ///字符串输入
                t = BigDecimal.valueOf(1);
                ans = BigDecimal.valueOf(0);
                
                int i, sta = st.indexOf('.');//找到第一次出现'.'  的位置
                for(i = sta+1; i < st.length(); ++i){              ///获取字符串长度只能用length()方法
                    tmp = BigDecimal.valueOf(st.charAt(i) - '0');  //charAt()获取当前位置的字符
                    t = t.divide(new BigDecimal("8"));           //大数只能和大数进行运算,Int只能与Int String只能和String
                    tmp = tmp.multiply(t);//乘
                    ans = ans.add(tmp);//加
                }
            System.out.println(st + " [8] = " + ans +  " [10]"); ///也可用System.out.printf();
            }
        }
    }
  • 相关阅读:
    Centos8 yum 源不可用
    Docker 容器开启SSH
    kubernetes calico 启动异常,无法访问etcd
    JEEGC相关笔记
    JS 的加减乘除 bobo
    go gin 项目热部署
    C#命名规范
    go 的定时器
    golang gin的安装和引入
    《十分钟冥想》摘要
  • 原文地址:https://www.cnblogs.com/ya-cpp/p/4025576.html
Copyright © 2020-2023  润新知