• hdu2602 Bone Collector 01背包


    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

     
    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     
    Sample Input
    1
    5 10
    1 2 3 4 5
    5 4 3 2 1
     
    Sample Output
    14
     
    题解:
          在容量为m的背包中放入骨头,每个骨头有一定的体积和一定的价值,问如何装能使背包中背的骨头价值最大。典型的01背包问题,套用模板即可。
          我写了两个,分别是一维数组和二维数组,一起发上来。
     
    代码1:
    #include <bits/stdc++.h>
    
    using namespace std;
    int t,n,m,v[1002],w[1002],i,j,f[1002][1002];
    int main()
    {
        cin>>t;
        while(t--){
            cin>>n>>m;
            for(i=1;i<=n;i++) cin>>v[i];
            for(i=1;i<=n;i++) cin>>w[i];
            memset(f,0,sizeof(f));
            for(i=1;i<=n;i++)          //装入第i个骨头时,背包容量为j时的最大价值
            for(j=0;j<=m;j++){
                if(j<w[i]){
                    f[i][j]=f[i-1][j];
                }
                else{
                    f[i][j]=max(f[i-1][j],f[i-1][j-w[i]]+v[i]);
                }
            }
            cout<<f[n][m]<<endl;
        }
        return 0;
    }
    代码2:
     
    #include <bits/stdc++.h>
    
    using namespace std;
    int n,m,f[1003],v[1003],w[1003],i,j,t;
    
    int main()
    {
        cin>>t;
        while(t--){
            cin>>n>>m;
            for(i=1;i<=n;i++) cin>>v[i];
            for(i=1;i<=n;i++) cin>>w[i];
            memset(f,0,sizeof(f));
            for(i=1;i<=n;i++)
            for(j=m;j>=w[i];j--){
                if(f[j]<f[j-w[i]]+v[i])
                    f[j]=f[j-w[i]]+v[i];
            }
            cout<<f[m]<<endl;
        }
        return 0;
    }
     
     
     
  • 相关阅读:
    循环结构
    位运算符
    Switch 选择结构
    if结构和逻辑运算符
    变量和运算符
    [luogu1090 SCOI2003] 字符串折叠(区间DP+hash)
    [luogu2329 SCOI2005] 栅栏(二分+搜索)
    [luogu 4886] 快递员
    [luogu4290 HAOI2008]玩具取名(DP)
    [luogu2624 HNOI2008]明明的烦恼 (prufer+高精)
  • 原文地址:https://www.cnblogs.com/y1040511302/p/9675964.html
Copyright © 2020-2023  润新知