• poj 1426 Find The Multiple (简单搜索dfs)


    题目:

    Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

    Input

    The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

    Output

    For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

    Sample Input

    2
    6
    19
    0

    Sample Output

    10
    100100100100100100
    111111111111111111

    题意:

            本题要找出数m,m是只有0和1构成的十进制数,并且是n的倍数,若有多个答案,输出任意一个就可以。

    题解:

            经过思考会发现m最大不会超过unsigned long long 的范围,所以用unsigned long long保存就可以,接下来就是深搜就ok。

    代码:

    #include <iostream>
    
    using namespace std;
    unsigned long long ans;
    bool f;
    
    void dfs(unsigned long long s,int n,int k)
    {
        if(f) return ;
        if(s%n==0) {ans=s;f=true; return ;}
        if(k==19) return ;        //如果k超过19就不在unsigned long long的范围内了
        dfs(s*10,n,k+1);
        dfs(s*10+1,n,k+1);
        return ;
    }
    
    int main()
    {
        int n;
        while(cin>>n,n)
        {
            ans=0;
            f=false;
            dfs(1,n,0);
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Algorithms
    STL学习笔记 set
    HttpContext.Current
    Luence初始与简单应用Document的增删改查.
    [深入浅出Cocoa]iOS程序性能优化
    spring.net结合普通三层(实现IOC 及AOP中的异常记录功能)
    VS版权信息插件——初试VS插件开发小记
    快速开发平台 Putdb WebBuilder 6.9
    ObjectiveC学习及iOS开发的准备
    Visual Studio 2012 Update 2 自制iso下载
  • 原文地址:https://www.cnblogs.com/y1040511302/p/10177925.html
Copyright © 2020-2023  润新知