• Quoit Design


    Quoit Design

    Problem Description
    Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
    In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

    Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
     

    Input
    The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
     

    Output
    For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
     

    Sample Input
    2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
     

    Sample Output
    0.71 0.00 0.75
     

    Author
    CHEN, Yue
     

    Source
    ZJCPC2004

    求一堆坐标里最短的坐标之间的距离的1/2

     

     

     

    #include<iostream>
    #include<algorithm>
    #include<cmath>
    #include<cstdio>
    using namespace std;
    #define max_v 100005
    int n;
    struct node
    {
        double x,y;
    }p[max_v];
    int a[max_v];
    double cmpx(node a,node b)
    {
        return a.x<b.x;
    }
    double cmpy(int a,int b)
    {
        return p[a].y<p[b].y;
    }
    double min_f(double a,double b)
    {
        return a<b?a:b;
    }
    double dis(node a,node b)
    {
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    double slove(int l,int r)
    {
        if(r==l+1)
            return dis(p[l],p[r]);
        if(l+2==r)
            return min_f(dis(p[l],p[r]),min_f(dis(p[l],p[l+1]),dis(p[l+1],p[r])));
        int mid=(l+r)>>1;
        double ans=min_f(slove(l,mid),slove(mid+1,r));
        int i,j,cnt=0;
        for( i=l;i<=r;i++)
        {
            if(p[i].x>=p[mid].x-ans&&p[i].x<=p[mid].x+ans)
            {
                a[cnt++]=i;
            }
        }
        sort(a,a+cnt,cmpy);
        for(i=0;i<cnt;i++)
        {
            for(j=i+1;j<cnt;j++)
            {
                if(p[a[j]].y-p[a[i]].y>=ans)
                    break;
                ans=min_f(ans,dis(p[a[i]],p[a[j]]));
            }
        }
        return ans;
    }
    int main()
    {
        int i;
        while(~scanf("%d",&n))
        {
            if(n==0)
                break;
            for(i=0;i<n;i++)
            {
                scanf("%lf %lf",&p[i].x,&p[i].y);
            }
            sort(p,p+n,cmpx);
            printf("%0.2lf\n",slove(0,n-1)/2.0);
        }
        return 0;
    }
     
  • 相关阅读:
    Mysql中的递归查询
    让git忽略对已经版本控制的文件的本地修改
    关于c#中逆变和协变的理解
    把之前的相关博客都迁到了博客园~
    结合github pages使用travis CI
    Spring中的Filter、HandlerInterceptor和AOP
    HDU1711 Number Sequence 题解 KMP算法
    HDU1358 Period 题解 KMP算法
    HDU1686 Oulipo 题解 KMP算法
    HDU3336 Count the string 题解 KMP算法
  • 原文地址:https://www.cnblogs.com/xxxsans/p/12672542.html
Copyright © 2020-2023  润新知