• 1056 Mice and Rice (25分)队列


    1.27刷题2

    Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

    First the playing order is randomly decided for NP​​ programmers. Then every NG​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​​ winners are then grouped in the next match until a final winner is determined.

    For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​​ and NG​​ (≤), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​​ distinct non-negative numbers Wi​​ (,) where each Wi​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 (assume that the programmers are numbered from 0 to NP​​1). All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    11 3
    25 18 0 46 37 3 19 22 57 56 10
    6 0 8 7 10 5 9 1 4 2 3
     

    Sample Output:

    5 5 5 2 5 5 5 3 1 3 5

    // 25 18 0 46 37 3 19 22 57 56 10
    // 6  0  8  7 10 5  9  1  4  2  3
    
    //题没看懂,其次要不是这个小结是队列,我根本想不起来用这个 
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    queue<int> q;
    // int maxabc(int a,int b,int c){  //题目给的ng是3,我就鬼迷心窍写个这。。 
    //     int max=-1;
    //     max=a>b?a:b;
    //     max=max>c?max:c;
    //     return max;
    // }
    struct mouse {//不用结构体多麻烦呀,为啥不用呀 
        int weight,record;
    } mice[maxn];
    int main() {
        int np,ng,b;
        cin>>np>>ng;
        
        for(int i=0; i<np; i++)cin>>mice[i].weight;
        for(int i=0; i<np; i++) {
            cin>>b;
            q.push(b);
        }
        int temp=np,group;//没想到
        while(q.size()!=1) {//这个循环是真的大 ,没想到是分组来排名的,确实还是模拟,就是按照思路写的代码 
            if(temp%ng==0)group=temp/ng;
            else group=temp/ng+1;
            for(int i=0; i<group; i++) {
                int k=q.front();
                for(int j=0; j<ng; j++) {
                    if(i*ng+j>=temp)break;
                    int front=q.front();
                    if(mice[front].weight>mice[k].weight)k=front;
    mice[front].record
    =group+1;//该轮老鼠排名为group+1 q.pop(); } q.push(k);//优胜者进决赛圈 } temp=group;//group在缩小 } mice[q.front()].record=1; for(int i=0; i<np; i++) { cout<<mice[i].record; if(i<np-1)cout<<" "; } }

    明天还有实习,还有复试,还有毕设,还有过年,还有春晚,还有黑眼圈,还有卷。

  • 相关阅读:
    组合索引
    常见的负载均衡策略
    jvm面试都有什么问题?
    Java常见面试题汇总-----------Java基础(NIO与IO的区别)
    关于OOM面试详解
    RabbitMQ几个常用面试题
    消息队列面试题及答案
    什么是B+树
    java并发编程 ||深入理解synchronized,锁的升级机制
    RabbitMQ中交换机的消息分发机制
  • 原文地址:https://www.cnblogs.com/xx123/p/14337635.html
Copyright © 2020-2023  润新知