• 快速切题 poj1129 Channel Allocation


    Channel Allocation
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 12334   Accepted: 6307

    Description

    When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

    Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

    Input

    The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

    Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

    A:BCDH 

    which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

    A: 

    The repeaters are listed in alphabetical order. 

    Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

    Output

    For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

    Sample Input

    2
    A:
    B:
    4
    A:BC
    B:ACD
    C:ABD
    D:BC
    4
    A:BCD
    B:ACD
    C:ABD
    D:ABC
    0

    Sample Output

    1 channel needed.
    3 channels needed.
    4 channels needed. 

    实际用时:21min
    原因:....心理准备
    #include <cstdio>
    #include <cstring>
    #include <vector>
    using namespace std;
    const int maxn=50;
    int n;
    vector <int > G[maxn];
    int color[maxn];
    int cnt;
    bool dfs(int s,int c){
        color[s]=c;
        for(int i=0;i<G[s].size();i++){
            int to=G[s][i];
            if(color[to]==c){color[s]=-1;return false;}
            if(color[to]==-1){
                for(int i=0;i<=cnt;i++){
                    if(i==cnt)cnt++;
                    if(i!=c&&dfs(to,i))break;
                }
            }
        }
        return true;
    }
    char buff[50];
    int main(){
        while(scanf("%d",&n)==1&&n){
            gets(buff);
            for(int i=0;i<n;i++){
                gets(buff);
                G[i].clear();
                for(int j=2;buff[j];j++){
                    G[i].push_back(buff[j]-'A');
                }
            }
            memset(color,-1,sizeof(color));
            cnt=1;
            for(int i=0;i<n;i++)if(color[i]==-1)dfs(i,0);
            if(cnt==1)printf("1 channel needed.\n");
            else printf("%d channels needed.\n",cnt);
        }
        return 0;
    }
    

      

  • 相关阅读:
    Tweet信息搜集工具tinfoleak
    Visual Studio 2017为Android APK包签名
    Arduino可穿戴教程之第一个程序——上传运行程序(四)
    基于NMAP日志文件的暴力破解工具BruteSpray
    CSS3边框圆角知识
    渐变的几个效果图
    错误类型
    prompt() 方法
    jQuery 遍历
    jquery的商品首页
  • 原文地址:https://www.cnblogs.com/xuesu/p/3993171.html
Copyright © 2020-2023  润新知