• 快速切题 poj2488 A Knight's Journey


    A Knight's Journey
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 31195   Accepted: 10668

    Description

    Background 
    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

    Problem 
    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

    Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
    If no such path exist, you should output impossible on a single line.

    Sample Input

    3
    1 1
    2 3
    4 3

    Sample Output

    Scenario #1:
    A1
    
    Scenario #2:
    impossible
    
    Scenario #3:
    A1B3C1A2B4C2A3B1C3A4B2C4

    实际用时 20min
    情况:CCCCA 注意java和胡乱改动
    注意点:1 组间空行但最后一组没有 2 字典序
    #include <cstdio>
    #include <cstring>
    using namespace std;
    int n,m;
    typedef unsigned long long ull;
    bool used[8][8];
    char heap[64][3];
    const int dx[8]={-2,-2,-1,-1,1,1,2,2},dy[8]={-1,1,-2,2,-2,2,-1,1};
    bool judge(int x,int y){
        if(x>=0&&x<n&&y>=0&&y<m)return true;
        return false;
    }
    bool dfs(int x,int y,int cnt){
        used[x][y]=true;
        heap[cnt][0]=x+'A';
        heap[cnt++][1]=y+'1';
        if(cnt==n*m)return true;
        for(int i=0;i<8;i++){
            int tx=x+dx[i],ty=y+dy[i];
            if(judge(tx,ty)&&!used[tx][ty]){
                if(dfs(tx,ty,cnt))return true;
            }
        }
        used[x][y]=false;
        return false;
    }
    int main(){
        int T;scanf("%d",&T);
        for(int ti=1;ti<=T;ti++){
            scanf("%d%d",&m,&n);
            memset(used,0,sizeof(used));
            bool fl=dfs(0,0,0);
            printf("Scenario #%d:\n",ti);
            if(fl){
                for(int i=0;i<n*m;i++){
                    printf("%s",heap[i]);
                }
                puts("");
            }
            else {
                puts("impossible");
            }
            if(ti<T)puts("");
        }
        return 0;
    }
    

      

  • 相关阅读:
    避坑!SimpleDateFormat不光线程不安全,还有这个隐患
    mybatisplus不支持sum,但支持这个
    spring @Cacheable使用SpEL异常:org.springframework.expression.spel.SpelParseException: Unexpected token. Expected 'identifier' but was 'lcurly({)'
    不扒瞎,这个程序让我从300s优化到了10s
    springboot启动报错BeanCreationException
    利用rabbitmq异步实现来提升程序处理性能
    项目主干分支的server.sh被“覆盖”了?一个配置,解除烦恼
    草图?不管黑猫白猫,能快速、有效把你的设计理念讲清楚才行
    FIRE记乐:编书的乐趣
    豆豆《背叛》:不能承受的恩情之重
  • 原文地址:https://www.cnblogs.com/xuesu/p/3992373.html
Copyright © 2020-2023  润新知