• poj 1163 The Triangle 搜索 难度:0


    The Triangle
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 37931   Accepted: 22779

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30
    记忆化搜索
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    const int maxn=211;
    int  num[maxn][maxn];
    int n,m;
    int maz[maxn][maxn];
    const int dx[2]={1,1},dy[2]={0,1};
    int dfs(int sx,int sy){
        if(num[sx][sy]!=-1)return num[sx][sy];
        int tmp=maz[sx][sy];
        for(int i=0;i<2;i++){
            int tx=sx+dx[i],ty=sy+dy[i];
            if(tx>=0&&tx<n&&ty>=0&&ty<tx+1){
                int t=dfs(tx,ty);
                tmp=max(t+maz[sx][sy],tmp);
            }
        }
        return num[sx][sy]=tmp;
    }
    int main(){
        int T=1;
        while(T--&&scanf("%d",&n)==1){
            for(int i=0;i<n;i++){
                for(int j=0;j<i+1;j++){
                    scanf("%d",maz[i]+j);
                }
            }
            memset(num,-1,sizeof(num));
            int ans=0;
            for(int i=0;i<n;i++){
                for(int j=0;j<i+1;j++){
                    if(num[i][j]==-1){
                        int tmp=dfs(i,j);
                        ans=max(ans,tmp);
                    }
                }
            }
            printf("%d\n",ans);
        }
        return 0;
    }
    

      

  • 相关阅读:
    安装 oracle 11g 发行版 出现错误:由于以下错误,Enterprise Manager配置失败,启动Database Control时出错
    ORACLE_SID的查找
    visual studio 2017 编译v140 TRACKER : error TRK0005: Failed to locate: "CL.exe". 系统找不到指定的文件
    mysql 数据库表名大小写问题
    Windows下部署mongodb
    where case 使用
    虚拟机,云服务器搭建vulhub靶场
    [De1CTF 2019]SSRF Me
    [2020YCTF]web1-rce_nopar
    [2020YCTF]
  • 原文地址:https://www.cnblogs.com/xuesu/p/3983123.html
Copyright © 2020-2023  润新知