• hdu_1040_As Easy As A+B_201308191751


    As Easy As A+B

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 29901    Accepted Submission(s): 12789


    Problem Description
    These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
    Give you some integers, your task is to sort these number ascending (升序).
    You should know how easy the problem is now!
    Good luck!
     
    Input
    Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
    It is guarantied that all integers are in the range of 32-int.
     
    Output
    For each case, print the sorting result, and one line one case.
     
    Sample Input
    2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
     
    Sample Output
    1 2 3 1 2 3 4 5 6 7 8 9
     
     

    //hdu-1040-As Easy As A+B
    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    #define MAX 1100

    int s[MAX];

    int cmp(const void *a,const void *b)
    {
        return *(int *)a - *(int *)b;
    }

    int main()
    {
        int N;
        scanf("%d",&N);
        while(N--)
        {
            int i,m;
            memset(s,0,sizeof(s));
            scanf("%d",&m);
            for(i=0;i<m;i++)
            scanf("%d",&s[i]);
            qsort(s,m,sizeof(s[0]),cmp);
            for(i=0;i<m;i++)
            {
                if(i<m-1)
                printf("%d ",s[i]);
                else
                printf("%d ",s[i]);
            }
        }
        return 0;
    }

    //简单题

  • 相关阅读:
    dotnet Framework 源代码 类库的意思
    dotnet Framework 源代码 类库的意思
    dotnet Framework 源代码 · Ink
    dotnet Framework 源代码 · Ink
    dotnet core 用值初始化整个数组
    dotnet core 用值初始化整个数组
    dotnet core 隐藏控制台
    dotnet core 隐藏控制台
    PHP mt_rand() 函数
    PHP mt_getrandmax() 函数
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3268377.html
Copyright © 2020-2023  润新知