• ACM 田忌赛马


    田忌赛马

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    Here is a famous story in Chinese history.

    "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

    "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

    "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

    "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

    "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

    In this problem, you are asked to write a program to solve this special case of matching problem.
     
    输入
    The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
    输出
    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

    样例输入
    3
    92 83 71
    95 87 74
    2
    20 20
    20 20
    2
    20 19
    22 18
    样例输出
    200
    0
    0

    贪心算法
    #include <vector>
    #include <algorithm>
    #include <iterator>
    #include <iostream>
    using namespace std;
    
    int main(){
        int n;
        while(cin >> n){
            vector<int> tian(n),king(n);
            for(int i = 0 ; i < n ; ++ i ) cin >> tian[i];
            for(int i = 0 ; i < n ; ++ i ) cin >> king[i];
            sort(tian.begin(),tian.end());
            sort(king.begin(),king.end());
            int leftTian = 0,leftKing = 0 , rightTian = tian.size()-1, rightKing = king.size()-1, sum = 0;
            while(leftTian <= rightTian){
                if(tian[rightTian] > king[rightKing]){
                    rightTian--;rightKing--;
                    sum += 200;
                }else if(tian[leftTian] > king[leftKing]){
                    leftTian++;leftKing++;
                    sum += 200;
                }else{
                    if(tian[leftTian] < king[rightKing]) sum-=200;
                    leftTian++;rightKing--;
                }
            }
            cout<<sum<<endl;
        }
    }
    
    
    
     
  • 相关阅读:
    第一节:理解垃圾回收平台的基本工作原理
    回想笔记 瞎比比 域名注册 解析绑定ip 下载证书 设置证书 重定向http到https请求
    flask 设置https请求 访问flask服务器
    关于 服务器ip和域名进行一个绑定
    ubuntu 安装flask+nginx+gunicorn 待定
    使用flask-dropzone 上传图片文件
    flask 对于用户登录保持状态 flask_login
    flask 对于邮件url进行一个加密防止爆破
    flask 密码加密 视频资料
    flask 多线程邮件异步发送 视频资料
  • 原文地址:https://www.cnblogs.com/xiongqiangcs/p/3663117.html
Copyright © 2020-2023  润新知