• [并查集] More is Better


    题目描述

    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

    输入

    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

    输出

    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

    样例输入

    3 1 3 1 5 2 5 4 3 2 3 4 1 6 2 6

    样例输出

    4 5
     
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    
    int f[10000001];
    int num[10000001];
    
    int findFather(int x)
    {
        int a=x;
        while(x!=f[x])
        {
            x=f[x];
        }
        while(a!=f[a])
        {
            int z=a;
            a=f[a];
            f[z]=x;
        }
        return x;
    }
    int ans=1;
    void unionf(int a,int b)
    {
        int fa=findFather(a);
        int fb=findFather(b);
        if(fa!=fb)
        {
            f[fa]=fb;
            num[fb]=num[fa]+num[fb];
            if(num[fb]>ans)
            {
                ans=num[fb];
            }
        }
    }
    
    void init()
    {
        for(int i=0;i<10000001;i++)
        {
            f[i]=i;
            num[i]=1;
        }
    }
    
    int main()
    {
        int n;
        while(cin>>n)
        {
            init();
            int a,b;
            ans=1;
            for(int i=0;i<n;i++)
            {
                cin>>a>>b;
                unionf(a,b);
                //cout<<"ans:"<<ans<<endl;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    H.264 RTP PAYLOAD 格式
    ARM:移动GPU往PC GPU效能迈进
    汪墩一中复校设想
    jconsole 和jvisualVM 监控远程 spring boot程序
    jenkins 登录远程机器并执行脚本,脚本中有后台执行的程序无法执行解决方法。
    linux下的抓包工具tcpdump
    adb logcat查看某个进程的输出日志
    Flask-SQLAlchemy 中多表链接查询(不使用外键)
    使用cnpm 安装vue.js
    Jmeter在非GUI环境下传递参数(命令行&Jenkins配置)
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6433398.html
Copyright © 2020-2023  润新知