• [并查集] How Many Tables


    题目描述

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    输入

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    输出

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

    样例输入

    2 6 4 1 2 2 3 3 4 1 4 8 10 1 2 2 3 5 6 7 5 4 6 3 6 6 7 2 5 2 4 4 3

    样例输出

    3 2
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    using namespace std;
    
    int f[1010];
    
    void init()
    {
        for(int i=0;i<1010;i++) f[i]=i;
    }
    
    int findFather(int x)
    {
        int a=x;
        while(x!=f[x])
        {
            x=f[x];
        }
        while(a!=f[a])
        {
            int z=a;
            a=f[a];
            f[z]=x;
        }
        return x;
    }
    
    int cnt=0;
    
    void unionf(int a,int b)
    {
        int fa=findFather(a);
        int fb=findFather(b);
        if(fa!=fb)
        {
            cnt-=1;
            f[fa]=fb;
        }
    }
    
    
    int main()
    {
        int t;
        cin>>t;
        for(int i=0;i<t;i++)
        {
            init();
            int n,m;
            cin>>n>>m;
            cnt=n;
            for(int j=0;j<m;j++)
            {
                int a,b;
                cin>>a>>b;
                unionf(a,b);
            }
            cout<<cnt<<endl;
        }
    }
  • 相关阅读:
    图解JAVA对象的创建过程
    统计机器学习
    排序算法简介及其C实现
    linux中强大的screen命令
    C语言注释
    Hello hadoop——使用hadoop进行大规模数据的全局排序
    Hadoop Streaming框架使用(二)
    shell——tr的用法
    统计学习方法《文本分类(三)》
    hadoop 常存问题
  • 原文地址:https://www.cnblogs.com/xiongmao-cpp/p/6433390.html
Copyright © 2020-2023  润新知