• HDU2317:Nasty Hacks


    Problem Description
    You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
    to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

     
    Input
    The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -10 6  ≤ r, e ≤ 10 6  and 0 ≤ c ≤ 10 6.
     
    Output
    Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
     
    Sample Input
    3 0 100 70 100 130 30 -100 -70 40
     
    Sample Output
    advertise does not matter do not advertise
     


     

    每天必水啊啊啊

    #include <stdio.h>
    
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int r,e,c;
            scanf("%d%d%d",&r,&e,&c);
            if(e-c > r)
            printf("advertise\n");
            else if(e-c == r)
            printf("does not matter\n");
            else if(e-c < r)
            printf("do not advertise\n");
        }
    
        return 0;
    }
    


     

  • 相关阅读:
    想要学习设计模式,你得先会看类图,一张图读懂UML
    UML类图中箭头的含义
    DDD学习
    Customize your build
    WaitAll vs WhenAll
    When does a C# Task actually start?
    UE4中多种颜色轮廓线的后期处理
    [UE4]武器碰撞
    动态材质实例(Dynamic Material Instance)
    卷积运算
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/3010942.html
Copyright © 2020-2023  润新知