• hdu1328——IBM Minus One


    原题:

    Problem Description
    You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

    After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

    Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.
     


     

    Input
    The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.
     


     

    Output
    For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

    Print a blank line after each test case.
     


     

    Sample Input
    2 HAL SWERC
     


     

    Sample Output
    String #1 IBM String #2 TXFSD

    分析:

    水题,不解释~~~~~~~~~~~~~~~

    加油吧、少年~!!!!!!!!!!!!

    原码:

    #include<stdio.h>
    #include<string.h>
    int main()
    {
        char str[66];
        int i;
        int n,k;
        scanf("%d",&n);
        for(k=1; k<=n; k++)
        {
            scanf("%s",str);
            int l=strlen(str);
            for(i=0; i<l; i++)
            {
                if(str[i]=='Z')
                    str[i]='A';
                else
                    str[i]++;
            }
            printf("String #%d\n",k);
            printf("%s\n",str);
            printf("\n");
        }
        return 0;
    }
    


     

  • 相关阅读:
    Windows常用命令
    Linux常用命令
    SpringBoot实现动态数据源切换及单库事务控制
    ArrayList与LinkedList
    java学习笔记之集合—ArrayList源码解析
    java学习笔记之反射—反射和工厂模式
    java学习笔记之反射—Class类实例化和对象的反射实例化
    java学习笔记之IO编程—对象序列化
    java学习笔记之IO编程—打印流和BufferedReader
    java学习笔记之IO编程—内存流、管道流、随机流
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/2992003.html
Copyright © 2020-2023  润新知