• sicily 1036 字符串解码 数组与下标解题


    1036. Crypto Columns

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

    The columnar encryption scheme scrambles the letters in a message (or plaintext) using a keyword as illustrated in the following example: Suppose BATBOY is the keyword and our message is MEET ME BY THE OLD OAK TREE. Since the keyword has 6 letters, we write the message (ignoring spacing and punctuation) in a grid with 6 columns, padding with random extra letters as needed:

    MEETME
    BYTHEO
    LDOAKT
    REENTH

    Here, we've padded the message with NTH. Now the message is printed out by columns, but the columns are printed in the order determined by the letters in the keyword. Since A is the letter of the keyword that comes first in the alphabet, column 2 is printed first. The next letter, B, occurs twice. In the case of a tie like this we print the columns leftmost first, so we print column 1, then column 4. This continues, printing the remaining columns in order 5, 3 and finally 6. So, the order the columns of the grid are printed would be 2, 1, 4, 5, 3, 6, in this case. This output is called the ciphertext, which in this example would be EYDEMBLRTHANMEKTETOEEOTH. Your job will be to recover the plaintext when given the keyword and the ciphertext.

    Input

    There will be multiple input sets. Each set will be 2 input lines. The first input line will hold the keyword, which will be no longer than 10 characters and will consist of all uppercase letters. The second line will be the ciphertext, which will be no longer than 100 characters and will consist of all uppercase letters. The keyword THEEND indicates end of input, in which case there will be no ciphertext to follow.

    Output

    For each input set, output one line that contains the plaintext (with any characters that were added for padding). This line should contain no spacing and should be all uppercase letters.

    Sample Input

    BATBOY
    EYDEMBLRTHANMEKTETOEEOTH
    HUMDING
    EIAAHEBXOIFWEHRXONNAALRSUMNREDEXCTLFTVEXPEDARTAXNAARYIEX
    THEEND

    Sample Output

    MEETMEBYTHEOLDOAKTREENTH
    ONCEUPONATIMEINALANDFARFARAWAYTHERELIVEDTHREEBEARSXXXXXX

    #include <iostream>
    #include <algorithm>
    #include <map>
    #include <cstring>
    using namespace std;
    bool cmp (const char a, const char b) {
    	return a < b;
    }
    int main() {
    	string keyword;
    	string ciphertext;
    	
    	while (cin >> keyword && keyword.compare("THEEND") != 0) {
    		cin >> ciphertext;
    		
    		map<int, char> key_order;
    		for (int i = 0; i < keyword.length(); i++) {
    			key_order[i] = keyword[i]; //i代表keyword中的该字符对应的子串应该位于第几列 
    		}
    		
    		sort(keyword.begin(), keyword.end(), cmp);//对keyword进行升序排序,使得每个字符依次与输入的字符串的子串对应 
    		
    		string sub_strs[keyword.length()]; //字符列 
    		int sub_s = 0; //每列字符串的开始坐标 
    		int sub_e = ciphertext.length() / keyword.length(); //每列字符串的结束坐标 
    		bool visited[keyword.length()]; //visited用于记录已经访问过得字符,避免出现如ABBCD这样每次都访问到第一个B的情况 
    		memset(visited, false, sizeof(visited));
    		
    		for (int i = 0; i < keyword.length(); i++) { //遍历排序后的keyword
    		    //对每个字符扫描key_order来决定把keyword中的该字符放在哪个列中 
    			for (int j = 0; j < keyword.length(); j++) { //根据key_order觉得把对应的子串放到哪列中,即j列 
    				if (key_order[j] == keyword[i] && visited[j] == false) {			
    					sub_strs[j] = ciphertext.substr(sub_s, sub_e);
    					sub_s = sub_e;
    					sub_e += ciphertext.length() / keyword.length();
    					visited[j] = true;
    					break;
    				}
    			}
    		}
    		//从左到右,从上到下依次输出 
    		for (int i = 0; i < ciphertext.length() / keyword.length(); i++) {
    			for (int j = 0; j < keyword.length(); j++)
    			cout << sub_strs[j].at(i);
    		}
    		cout << endl;
    	}
    	return 0;
    } 
    

      

  • 相关阅读:
    selenium===介绍
    工具安装===Sublime Text-安装
    Django===django工作流
    python基础=== itertools介绍(转载)
    python基础===如何优雅的写代码(转自网络)
    python基础===一道小学奥数题的解法
    python基础===列表类型的所有方法
    python基础===通过菲波那契数列,理解函数
    python基础===字符串切片
    安全测试===BurpSuite使用教程-附安装包
  • 原文地址:https://www.cnblogs.com/xieyizun-sysu-programmer/p/4005077.html
Copyright © 2020-2023  润新知