• A + B Problem II201308072001.txt


    A + B Problem II
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 166925    Accepted Submission(s): 31927


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
     

    Sample Output
    Case 1:
    1 + 2 = 3

    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     


    #include <stdio.h>
    #include <string.h>
    #define MAX 1000
    int main()
    {
        char an1[MAX+100];
        char an2[MAX+100];
        int an3[MAX+100];
        int an4[MAX+100];
        int n,k=0,p=0;
        scanf("%d",&n);
        while(n--)
        {
         int i,j,m,l;
         scanf("%s%s",an1,an2);
         memset(an3,0,sizeof(an3));
         memset(an4,0,sizeof(an4));
         l=strlen(an1);
            for(i=l-1,j=0;i>=0;i--)
            an3[j++]=an1[i]-'0';
            m=strlen(an2);
            for(i=m-1,j=0;i>=0;i--)
            an4[j++]=an2[i]-'0';
            for(i=0;i<MAX+100;i++)
            {
             an3[i]+=an4[i];
            if(an3[i]>=10)
            {
             an3[i]-=10;
                an3[i+1]+=1;
            }
            }
            k++;
            printf(p++?" Case %d: ":"Case %d: ",k);
            //printf("Case %d: %s + %s = ",k,an1,an2);
            printf("%s + %s = ",an1,an2);
            for(i=MAX+99;(i>0)&&(an3[i]==0);i--);
            for(j=i;j>=0;j--)
             printf("%d",an3[j]);
                printf(" ");
        }
        return 0;
    }
             
           
           
           
           
           
           
           
           
           
           

  • 相关阅读:
    使用 SailingEase WinForm 框架构建复合式应用程序(插件式应用程序)
    SailingEase WinForm 应用程序开发框架
    SailingEase WinForm 框架 DEMO 下载
    SailingEase WinForm 开发框架
    .net动态编译
    VS2010 如何修改程序菜单字体大小?
    Android C++回收机制(转)
    遥测的死区
    发现个开源很好的C++框架库,共享一下
    mongodb查询例子
  • 原文地址:https://www.cnblogs.com/xiaziteng/p/dashuwenti.html
Copyright © 2020-2023  润新知