• POJ2421Constructing Roads


    Description

    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input

    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output

    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

    Sample Input

    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
    

    Sample Output

    179

    解题报告:这是一道最小生成树的问题,这题是数据不是很大,所以可以选择使用prime算法或者克鲁斯卡尔算法,相对来说,选择prime算法要简单一些,这题的有一
    个特殊的要求就是会给出一些已经修建了的公路,解决此问题的办法是将已经修建的公路的对应的权值设成0;这样就相当于没有将这条路加入到集合当中。下面附上AC代码:

    #include<stdio.h>
    int visit[5000],N,Q,map[5000][5000],sum=0;
    int find(int i,int x) {
     return (i==x? i:find(x,visit[x]));
    }
    struct node {
     int front,rear,length;
    }lode[5000];
    void popsort(int n) {
     for(int i=1;i<=n;++i)
     for(int j=1;j<=n-1;++j)
     if(lode[j].length>lode[j+1].length) {
      struct node d=lode[j];
      lode[j]=lode[j+1];
      lode[j+1]=d;
     }
    }
    int main() {
     while(scanf("%d",&N)!=EOF) {
      for(int i=1;i<=N;++i)
      visit[i]=i;
      for(int i=1;i<=N;++i)
      for(int j=1;j<=N;++j)
      scanf("%d",&map[i][j]);
      scanf("%d",&Q);
      int x,y;
      for(int i=1;i<=Q;++i) {
       scanf("%d%d",&x,&y);
       map[y][x]=0;
      }
      int z=0;
      for(int i=1;i<=N;++i)
      for(int j=1;j<i;++j) {
       lode[++z].front=j;
       lode[z].rear=i;
       lode[z].length=map[i][j];
      }
      popsort(z);
      for(int i=1;i<=z;++i)
       if(find(lode[i].front,visit[lode[i].front])!=find(lode[i].rear,visit[lode[i].rear])) {
         sum+=lode[i].length;
         visit[find(lode[i].front,visit[lode[i].front])]=lode[i].rear;
       }
      printf("%d\n",sum);
     }
     return 0;
    }

  • 相关阅读:
    C# windows窗口应用程序切换主界面的显示内容
    C# WinFrom 发送邮件
    asp.net开发微信公众平台----目录汇总-持续更新
    web css
    C#:XML操作类
    SQL Server -- 回忆笔记(五):T-SQL编程,系统变量,事务,游标,触发器
    C# -- 随机数产生的字母金字塔
    SQL Server -- 回忆笔记(四):case函数,索引,子查询,分页查询,视图,存储过程
    SQL Server -- 回忆笔记(三):ADO.NET之C#操作数据库
    SQL Server -- 回忆笔记(二):增删改查,修改表结构,约束,关键字使用,函数,多表联合查询
  • 原文地址:https://www.cnblogs.com/xiaxiaosheng/p/3031521.html
Copyright © 2020-2023  润新知