• HDU2052Picture


    Problem Description
    Give you the width and height of the rectangle,darw it.
     
    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
     
    Output
    For each case,you should draw a rectangle with the width and height giving in the input. after each case, you should a blank line.
     
    Sample Input
    3 2
     
    Sample Output
    +---+ | | | | +---+
     
    #include<stdio.h>
    int main() {
        int
    n,m;
        while
    (scanf("%d%d",&n,&m)!=EOF){
            printf("+");
            for
    (int i=1;i<=n;++i)
            printf("-");
            printf("+\n");
            for
    (int i=1;i<=m;++i) {
                for
    (int j=1;j<=n+2;++j)
                if
    (j==1||j==(n+2)) printf("|");
                else

                printf(" ");
                printf("\n");
            }

            printf("+");
            for
    (int i=1;i<=n;++i)
            printf("-");
            printf("+\n\n");
        }

        return
    0;
    }
  • 相关阅读:
    修改手机端radio 样式
    css ul li 左对齐,换行
    8- 类
    virtualbox虚拟机上网方式
    HTTP请求头详解
    出差总结-2017-11-24
    Some characters cannot be mapped using "GBK" ...
    tortoisesvn与eclipse-svn的删除操作区别
    sql
    setInterval方法, clearInterval
  • 原文地址:https://www.cnblogs.com/xiaxiaosheng/p/3020390.html
Copyright © 2020-2023  润新知