• String Subtraction


    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

     

    Input Specification:

     

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

     

    Output Specification:

     

    For each test case, print S1 - S2 in one line.

     

    Sample Input:

    They are students.

    aeiou

    Sample Output:

    Thy r stdnts.



    //主要是时限,所以该想办法用Hash。
    
     
    
    #include <iostream>
    
    #include <string>
    
    #include <map>
    
    using namespace std;
    
     
    
    int main()
    
    {
    
     
    
          string ss1,ss2;
    
        int i;
    
          while(getline(cin,ss1))
    
          {
    
     
    
             getline(cin,ss2);
    
          
    
             map<char,bool> mm;
    
     
    
             for(i=0;i<ss1.length();i++)
    
                mm[ss1[i]]=true;
    
     
    
             for(i=0;i<ss2.length();i++)
    
                mm[ss2[i]]=false;
    
     
    
             for(i=0;i<ss1.length();i++)
    
                   if(mm[ss1[i]])
    
                        cout<<ss1[i];
    
     
    
                   cout<<endl;
    
          }
    
     
    
      return 0;
    
    }
    
     
    
     



  • 相关阅读:
    trie树模型
    计算机网络概念
    [luogu]1042乒乓球 (模拟)
    [IPUOJ10705]最大连通块 (dfs)
    IPUOJ10701 有障碍的八皇后
    【紫书学习笔记】
    纪念正式写博客的第一天
    Bzoj 1997 [Hnoi2010]Planar题解
    Bzoj 1925 [Sdoi2010]地精部落 题解
    Bzoj 2839 集合计数 题解
  • 原文地址:https://www.cnblogs.com/xiaoyesoso/p/4234439.html
Copyright © 2020-2023  润新知