• Pop Sequence (栈)


     Pop Sequence (栈)

     

    Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

     

    Input Specification:

     

    Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

     

    Output Specification:

     

    For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

     

    Sample Input:

    5 7 5

    1 2 3 4 5 6 7

    3 2 1 7 5 6 4

    7 6 5 4 3 2 1

    5 6 4 3 7 2 1

    1 7 6 5 4 3 2

    Sample Output:

    YES

    NO

    NO

    YES

    NO

     

     

    一个数要出栈,那么比这个数小的数一定要先进栈 

     

    设 tem 为进栈的数。如果 栈为空 或 出栈的数 不等于 栈顶数,那么 tem进栈 后 自增。如果 出栈的数 等于 栈顶数,则出栈。如果栈溢出,那就错误(可能是要出栈的数太大 或者是 要出栈的数 小于 此刻的栈顶元素 )


    #include <iostream>
    
    #include <string>
    
    #include<vector>
    
    #include <stack>
    
    using namespace std;
    
     
    
    int main()
    
    {
    
         
    
          int i,j,m,k,n,x;
    
          while(cin>>m)
    
          {
    
             cin>>n>>k;
    
         
    
             for(i=0;i<k;i++)
    
             {
    
              bool is=true;
    
                  stack<int> tt;
    
                  int tem=1;
    
                
    
                  for(j=0;j<n;j++)
    
                  {
    
                      
    
                  cin>>x;
    
                     while(tt.size()<=m && is)
    
                      {
    
                            if(tt.empty() || tt.top()!=x)
    
                                  tt.push(tem++);
    
                            else if(tt.top()==x)
    
                            {
    
                                tt.pop();
    
                                  break;
    
                            }
    
     
    
                      }
    
                      if(tt.size() > m)
    
                      {
    
                          is=false;
    
                      }
    
     
    
     
    
     
    
                  }
    
                   if(is) cout<<"YES"<<endl;
    
                   else cout<<"NO"<<endl;
    
     
    
             }
    
          }
    
     
    
      return 0;
    
    }



  • 相关阅读:
    Expect学习笔记(1)
    Awk 实例,第 3 部分
    ELF文件格式(中文版)
    sed 实例,第 1 部分
    Expect 教程中文版
    csc工具一般使用说明zz
    Microsoft Office Word 2010(zz)
    记录XPO查询 日志
    C#中判断文件或文件夹是否存在
    Discuz数据库结构1
  • 原文地址:https://www.cnblogs.com/xiaoyesoso/p/4234438.html
Copyright © 2020-2023  润新知