• [codeforces538D]Weird Chess


    [codeforces538D]Weird Chess

    试题描述

    Igor has been into chess for a long time and now he is sick of the game by the ordinary rules. He is going to think of new rules of the game and become world famous.

    Igor's chessboard is a square of size n × n cells. Igor decided that simple rules guarantee success, that's why his game will have only one type of pieces. Besides, all pieces in his game are of the same color. The possible moves of a piece are described by a set of shift vectors. The next passage contains a formal description of available moves.

    Let the rows of the board be numbered from top to bottom and the columns be numbered from left to right from 1 to n. Let's assign to each square a pair of integers (x, y) — the number of the corresponding column and row. Each of the possible moves of the piece is defined by a pair of integers (dx, dy); using this move, the piece moves from the field (x, y) to the field (x + dx, y + dy). You can perform the move if the cell (x + dx, y + dy) is within the boundaries of the board and doesn't contain another piece. Pieces that stand on the cells other than (x, y) and (x + dx, y + dy)are not important when considering the possibility of making the given move (for example, like when a knight moves in usual chess).

    Igor offers you to find out what moves his chess piece can make. He placed several pieces on the board and for each unoccupied square he told you whether it is attacked by any present piece (i.e. whether some of the pieces on the field can move to that cell). Restore a possible set of shift vectors of the piece, or else determine that Igor has made a mistake and such situation is impossible for any set of shift vectors.

    输入

    The first line contains a single integer n (1 ≤ n ≤ 50).

    The next n lines contain n characters each describing the position offered by Igor. The j-th character of the i-th string can have the following values:

    • o — in this case the field (i, j) is occupied by a piece and the field may or may not be attacked by some other piece;
    • x — in this case field (i, j) is attacked by some piece;
    • . — in this case field (i, j) isn't attacked by any piece.

    It is guaranteed that there is at least one piece on the board.

    输出

    If there is a valid set of moves, in the first line print a single word 'YES' (without the quotes). Next, print the description of the set of moves of a piece in the form of a (2n - 1) × (2n - 1) board, the center of the board has a piece and symbols 'x' mark cells that are attacked by it, in a format similar to the input. See examples of the output for a full understanding of the format. If there are several possible answers, print any of them.

    If a valid set of moves does not exist, print a single word 'NO'.

    输入示例

    6
    .x.x..
    x.x.x.
    .xo..x
    x..ox.
    .x.x.x
    ..x.x.

    输出示例

    YES
    ...........
    ...........
    ...........
    ....x.x....
    ...x...x...
    .....o.....
    ...x...x...
    ....x.x....
    ...........
    ...........
    ...........

    数据规模及约定

    见“输入

    题解

    我们把输入的地图叫“原图”,输出的图叫“攻击图”。

    可以发现,对于“原图”中每个 'o',对于任意一个 '.' 的位置,它在“攻击图”中对应的位置也是 '.',因为这个 'o' 是不可能攻击到该位置的。

    所以对于每个 'o',把所有 '.' 相对 'o' 的位置取个并,其它地方都是 'x',最后再大力 check 一波合法性就好了。

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    #include <stack>
    #include <vector>
    #include <queue>
    #include <cstring>
    #include <string>
    #include <map>
    #include <set>
    using namespace std;
    
    int read() {
    	int x = 0, f = 1; char c = getchar();
    	while(!isdigit(c)){ if(c == '-') f = -1; c = getchar(); }
    	while(isdigit(c)){ x = x * 10 + c - '0'; c = getchar(); }
    	return x * f;
    }
    
    #define maxn 110
    int n;
    char Map[maxn][maxn], Att[maxn][maxn];
    bool vis[maxn][maxn];
    
    int main() {
    	memset(Att, 'x', sizeof(Att));
    	n = read();
    	for(int i = 1; i <= n; i++) scanf("%s", Map[i] + 1);
    	
    	Att[n][n] = 'o';
    	for(int i = 1; i <= (n << 1) - 1; i++) Att[i][n<<1] = '';
    	for(int i = 1; i <= n; i++)
    		for(int j = 1; j <= n; j++) if(Map[i][j] == 'o')
    			for(int x = 1; x <= n; x++)
    				for(int y = 1; y <= n; y++) if(Map[x][y] == '.')
    					Att[n+x-i][n+y-j] = '.';
    	for(int i = 1; i <= n; i++)
    		for(int j = 1; j <= n; j++) if(Map[i][j] == 'o')
    			for(int x = 1; x <= n; x++)
    				for(int y = 1; y <= n; y++)
    					if(Map[x][y] == 'x' && Att[n+x-i][n+y-j] == 'x') vis[x][y] = 1;
    	bool ok = 1;
    	for(int i = 1; i <= n; i++)
    		for(int j = 1; j <= n; j++)
    			if(Map[i][j] == 'x' && !vis[i][j]){ ok = 0; break; }
    	
    	if(!ok) return puts("NO"), 0;
    	puts("YES");
    	for(int i = 1; i <= (n << 1) - 1; i++) puts(Att[i] + 1);
    	
    	return 0;
    }
    
  • 相关阅读:
    基本类型与引用类型
    局部变量与实例变量
    语句块
    i++与++i
    JAVA基本概念
    网线8根线的排列方式
    Docker容器常用命令
    内存cache使用的场景
    Python爬虫:Xpath语法笔记
    python实现简单的聊天
  • 原文地址:https://www.cnblogs.com/xiao-ju-ruo-xjr/p/6358895.html
Copyright © 2020-2023  润新知