• poj 3414 Pots(广搜BFS+路径输出)


    转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

    题目链接:http://poj.org/problem?

    id=3414

    此题和poj1606一样 :http://blog.csdn.net/u012860063/article/details/37772275


    Description

    You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

    1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
    2. DROP(i)      empty the pot i to the drain;
    3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

    Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

    Input

    On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

    Output

    The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

    Sample Input

    3 5 4

    Sample Output

    6
    FILL(2)
    POUR(2,1)
    DROP(1)
    POUR(2,1)
    FILL(2)
    POUR(2,1)

    题目大意:

    有二个水壶,对水壶有三种操作:

    1)FILL(i),将i水壶的水填满;

    2)DROP(i)。将水壶i中的水所有倒掉;

    3)POUR(i,j)将水壶i中的水倒到水壶j中。若水壶 j 满了,则 i 剩下的就不倒了,问进行多少步操作。而且怎么操作,输出操作的步骤,两个水壶中的水能够达到C这个水量。假设不可能则输出impossible

    初始时两个水壶是空的,没有水。


    代码例如以下:

    #include <iostream>
    #include <algorithm>
    using namespace std;
    #include <cstring>
    #include <queue>
    #include <stack>
    struct cup
    {
    	int x, y;
    	int step;
    	int flag;//标记操作
    	cup *pre;//记录路径
    };
    queue<cup>Q;
    stack<int>R;
    int a, b, e;
    int vis[117][117]={0};//标记当前状态是否到达过
    int ans;
    void BFS(int x, int y)
    {
    	cup c;
    	cup t[317];//眼下瓶子里剩余的水量
    	c.x = 0, c.y = 0;
    	c.flag = 0;
    	c.pre = NULL;
    	c.step = 0;
    	Q.push(c);
    	vis[x][y] = 1;
    	int count = -1;
    	while(!Q.empty())
    	{
    		count++;
    		t[count] = Q.front();
    		Q.pop();
    		for(int i = 1; i <= 6; i++)
    		{
    			switch(i)
    			{
    				case 1:						//fill a
    					c.x = a;
    					c.y = t[count].y;
    					c.flag = 1;
    					break;
    				case 2:						//fill b
    					c.x = t[count].x;
    					c.y = b;
    					c.flag = 2;
    					break;
    				case 3:						//drop a
    					c.x = 0;
    					c.y = t[count].y;
    					c.flag = 3;
    					break;
    				case 4:						//drop b
    					c.x = t[count].x;
    					c.y = 0;
    					c.flag = 4;
    					break;
    				case 5:						//pour a to b
    					if(t[count].x > b-t[count].y)
    					{
    						c.x = t[count].x-(b-t[count].y);
    						c.y = b;
    					}
    					else
    					{
    						c.x = 0;
    						c.y = t[count].y+t[count].x;
    					}
    					c.flag = 5;
    					break;
    				case 6:						//pour b to a
    					if(t[count].y > a-t[count].x)
    					{
    						c.y = t[count].y - (a-t[count].x);
    						c.x = a;
    					}
    					else
    					{
    						c.x = t[count].x+t[count].y;
    						c.y = 0;
    					}
    					c.flag = 6;
    					break;
    			}
    			if(vis[c.x][c.y])
    				continue;
    			vis[c.x][c.y] = 1;
    			c.step = t[count].step+1;
    			c.pre = &t[count];
    			if(c.x == e || c.y == e)
    			{
    				ans = c.step;
    				while(c.pre)
    				{
    					R.push(c.flag);
    					c = *c.pre;
    				}
    				return;
    			}
    			Q.push(c);
    		}
    	}
    }
    void print()
    {
    	while(!R.empty())
    	{
    		int i = R.top();
    		R.pop();
    		switch(i)
    		{
    			case 1:cout<<"FILL(1)"<<endl;break;
    			case 2:cout<<"FILL(2)"<<endl;break;
    			case 3:cout<<"DROP(1)"<<endl;break;
    			case 4:cout<<"DROP(2)"<<endl;break;
    			case 5:cout<<"POUR(1,2)"<<endl;break;
    			case 6:cout<<"POUR(2,1)"<<endl;break;
    		}
    	}
    }
    int main()
    {
    	cin >>a>>b>>e;
    	BFS(0,0);
    	if(ans == 0)
    		cout<<"impossible"<<endl;
    	else
    	{
    		cout<<ans<<endl;
    		print();
    	}
    	return 0;
    }


  • 相关阅读:
    异常总结201304
    Android开发资料[20121125]
    大素数的生成
    django 获取用户IP地址
    python包管理工具pip
    mysql大表修改结构
    素数的检测
    一致性哈希算法 python实现
    素数的生成筛选法
    相似哈希simhash
  • 原文地址:https://www.cnblogs.com/wzzkaifa/p/6729345.html
Copyright © 2020-2023  润新知