• P


    来源poj1422

    Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

    With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

    Input

    Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

    no_of_intersections
    no_of_streets
    S1 E1
    S2 E2
    ......
    Sno_of_streets Eno_of_streets

    The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

    There are no blank lines between consecutive sets of data. Input data are correct.

    Output

    The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

    sample Input

    2
    4
    3
    3 4
    1 3
    2 3
    3
    3
    1 3
    1 2
    2 3

    Sample Output

    2
    1

    要多少个人才能走完所有路,最小路径覆盖,用匈牙利算法,最小路=总节点-最大匹配

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<float.h> 
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<queue>
    #include<map>
    #define rep(i,a,n) for (int i=a;i<n;i++)
    #define per(i,a,n) for (int i=a;i>=n;i--)
    typedef long long ll;
    const ll mod=1e9+100;
    const double eps=1e-8;
    using namespace std;
    const double pi=acos(-1.0);
    const int inf=0xfffffff;
    const int N=220;
    int pre[N];
    int visit[N],line[N][N];
    char Map[N][N];
    int n,m,y,x;
    bool find(int x)
    {
    	rep(i,1,n+1)
    	{
    		if(line[x][i]&&visit[i]==0)
    		{
    			visit[i]=1;
    			if(pre[i]==0||find(pre[i]))
    			{
    				pre[i]=x;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    int main()
    {
    	int re;
    	cin>>re;
    	while(re--)
    	{
    		mm(line,0);
    		mm(pre,0);
    		cin>>n>>m;
    		rep(i,0,m)
    		{
    			cin>>x>>y;
    			line[x][y]=1;
    		}
    		int ans=0;
    		rep(i,1,n+1)
    		{
    			mm(visit,0);
    			if(find(i)) ans++;
    		}
    		cout<<n-ans<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    html中frameset的详细使用方法
    日期控件API
    限制input输入类型(多种方法实现)
    springmvc导出excel并弹出下载框
    Spring mvc 验证码的做法
    Spring Boot 集成MyBatis
    Spring Boot 实践折腾记(三):三板斧,Spring Boot下使用Mybatis
    支付系统架构
    javaScript事件(六)事件类型之滚轮事件
    你不是真正的快乐
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9458630.html
Copyright © 2020-2023  润新知