• D


    n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.
    Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.
    This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

    Input

    The first line contains an integer t (1≤t≤500) which is the number of test cases.
    For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b.

    Output

    For each test case, output the winner (Yuwgna" or Iaka"). Both of them will make the best possible decision each time.

    Sample Input

    16
    2 1 2
    3 1 3
    67 1 2
    100 1 2
    8 6 8
    9 6 8
    10 6 8
    11 6 8
    12 6 8
    13 6 8
    14 6 8
    15 6 8
    16 6 8
    1314 6 8
    1994 1 13
    1994 7 12

    Sample Output

    Case #1: Iaka
    Case #2: Yuwgna
    Case #3: Yuwgna
    Case #4: Iaka
    Case #5: Iaka
    Case #6: Iaka
    Case #7: Yuwgna
    Case #8: Yuwgna
    Case #9: Iaka
    Case #10: Iaka
    Case #11: Yuwgna
    Case #12: Yuwgna
    Case #13: Iaka
    Case #14: Yuwgna
    Case #15: Iaka
    Case #16: Iaka

    自己设几个数模拟一下,可以发现,他们只能相差两个人的最大公约数,然后看看有奇数个还是偶数个就可以了

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #define mm(a,b) memset((a),(b),sizeof(a))
    #include<vector>
    typedef __int64 ll;
    typedef long double ld;
    const ll mod=1e9+7;
    using namespace std;
    const double pi=acos(-1.0);
    int gcd(int a,int b)
    {
    	return b==0?a:gcd(b,a%b);
     }
    bool judge(int m,int a,int b)
    {
    		int x=gcd(a,b);
    		int num=m/x;
    		if(num&1)
    			return false;
    		else
    			return true;
    }
    int main()
    {
    	int n;
    	cin>>n;
    	for(int i=1;i<=n;i++)
    	{
    		int m,a,b;
    		sf("%d%d%d",&m,&a,&b);
    		if(judge(m,a,b))
    		pf("Case #%d: Iaka
    ",i);
    		else
    		pf("Case #%d: Yuwgna
    ",i);	
    	}
    	return 0;
    }
    
  • 相关阅读:
    Mysql 交集、并集、差集、行转列、列转行
    Scala隐式转换
    ES添加elasticsearch-sql插件
    ES添加elasticsearch-analysis-ik分词器
    ES添加Head插件
    ES操作详解
    ES集群安装
    Scala上下界以及比较器Ordered
    Java对象比较
    解方程(来自学长的“遗产”)
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9356710.html
Copyright © 2020-2023  润新知