• A


    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

    To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

    Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

    FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

    Input

    Line 1: Three space-separated integers: L, N, and M
    Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2
    2
    14
    11
    21
    17

    Sample Output

    4

    Hint

    Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

    用二分,找到是否符合条件的间距

    There is a literal backtick (`) here.

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #include<vector>
    typedef long long ll;
    typedef long double ld;
    const ll MOD=1e9+7;
    using namespace std;
    ll a[50005];
    ll l,n,num;
    bool judge(ll mid)
    {
    	int bits=0;
    	for(int i=0;i<n;i++)
    	{
    		int ans=0;
    		for(int j=1;j<=n-i;j++)
    		{
    			if(a[i+j]-a[i]<mid)
    			{
    				ans++;
    				bits++;
    			}else
    			break;
    		}
    		i+=ans;
    		if(bits>num)
    		{
    			return true;
    		}
    	}
    	return false;
    }
    int main()
    {
    	
    	a[0]=0;
    	cin>>l>>n>>num;
    	for(int i=1;i<=n;i++)
    	cin>>a[i];
    	a[n+1]=l;
    	n++;
    	sort(a,a+n+1);
    	ll left=0,right=l,mid=(left+right)/2;
    	while(right-left>1)
    	{
    		
    		if(judge(mid))
    		{
    			right=mid;
    		}else
    		{
    			left=mid;
    		}
    		mid=(left+right)/2;
    	}
    	while(!judge(mid))mid++;
    	cout<<mid-1;
    } 
    
  • 相关阅读:
    【AtCoder】ARC075
    【BZOJ】3022: [Balkan2012]The Best Teams
    【Codeforces】Gym100633 D. LWDB
    MIME协议在邮件中的应用详解
    struts返回json数据
    mysql-存储过程(转载)
    安卓OKhttp请求封装
    安卓动态添加碎片
    通过163smtp服务器向各大邮箱发送邮件(SOCKET编程)
    安卓原生与hml交互(WebView基础)
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9347693.html
Copyright © 2020-2023  润新知