• 描述


    描述

    It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

    The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

    Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

    Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

    Print your answer as the total number of stalls blocked.

    输入

    Line 1:           M, S, and C (space separated) 
    Lines 2-C+1:  Each line contains one integer, the number of an occupied stall.

    输出

    A single line with one integer that represents the total number of stalls blocked.

    样例输入

    4 50 18
    3
    4
    6
    8
    14
    15
    16
    17
    21
    25
    26
    27
    30
    31
    40
    41
    42
    43

    样例输出

    25

    解题思路:贪心去掉间隙最大的m-1段

    #include <bits/stdc++.h>
    using namespace std;
    const int N=5005;
    int a[N],b[N];
    int main()
    {
        int n,m,s,c,k=0;
        cin>>m>>s>>c;
        for(int i=1;i<=c;i++) cin>>a[i];
        sort(a+1,a+1+c);
        for(int i=2;i<=c;i++){
            b[++k]=a[i]-a[i-1];
        }
        sort(b+1,b+1+k);
        s=a[c]-a[1]+1;
        for(int i=1;i<m;i++){
            if(k-i+1>=1) s=s-b[k-i+1]+1;
        }
        cout<<s<<endl;
    } 
  • 相关阅读:
    微信小程序基础 | 小程序事件的绑定 | 08
    Python的驻留机制(仅对数字,字母,下划线有效)
    深浅Copy的理解
    python2/3区别
    Python的优缺点、以及解释器种类
    Python涉及的各个领域以及技术应用
    近年主流编程语言的了解
    编程语言(机器语言、汇编语言、高级语言)
    mysql常用SQL语句
    mysql数据库的优缺点
  • 原文地址:https://www.cnblogs.com/ww123/p/11640375.html
Copyright © 2020-2023  润新知