• Marriage is Stable


    Marriage is Stable

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 64 Accepted Submission(s): 43
     
    Problem Description
    Albert, Brad, Chuck are happy bachelors who are in love with Laura, Marcy, Nancy. They all have three choices. But in fact, they do have some preference in mind. Say Albert, he likes Laura best, but that doesn't necesarily mean Laura likes him. Laura likes Chuck more than Albert. So if Albert can't marry Laura, he thinks Nancy a sensible choice. For Albert, he orders the girls Laura > Nancy > Marcy.

    For the boys:

    Albert: Laura > Nancy > Marcy
    Brad: Marcy > Nancy > Laura
    Chuck: Laura > Marcy > Nancy

    For the girls:

    Laura: Chuck > Albert > Brad
    Marcy: Albert > Chuck > Brad
    Nancy: Brad > Albert > Chuck

    But if they were matched randomly, such as

    Albert <-> Laura
    Brad <-> Marcy
    Chuck <-> Nancy

    they would soon discover it's not a nice solution. For Laura, she likes Chuck instead of Albert. And what's more, Chuck likes Laura better than Nancy. So Laura and Chuck are likely to come together, leaving poor Albert and Nancy.

    Now it's your turn to find a stable marriage. A stable marriage means for any boy G and girl M, with their choice m[G] and m[M], it will not happen that rank(G, M) < rank(G, m[G])and rank(M, G) < rank(M, m[M]).
     
    Input
    Each case starts with an integer n (1 <= n <= 500), the number of matches to make.

    The following n lines contain n + 1 names each, the first being name of the boy, and rest being the rank of the girls.

    The following n lines are the same information for the girls.

    Process to the end of file.
     
    Output

                If there is a stable marriage, print n lines with two names on each line. You can choose any one if there are multiple solution. Print "Impossible" otherwise.

    Print a blank line after each test.
     
    Sample Input
    3
    Albert Laura Nancy Marcy
    Brad Marcy Nancy Laura
    Chuck Laura Marcy Nancy
    Laura Chuck Albert Brad
    Marcy Albert Chuck Brad
    Nancy Brad Albert Chuck
     
    Sample Output
    Albert Nancy
    Brad Marcy
    Chuck Laura
     
    Author
    CHENG, Long
     
    Source
    ZOJ
     
    Recommend
    8600
     
    /*
    题意:给你n个男生暗恋的对象,n个女生暗恋的对象,如果刚好能组成n对不重复的情侣,就输出,如果不可能的话,就输出Impossible
    
    初步思路:很典型的二分匹配问题
    */
    #include<bits/stdc++.h>
    using namespace std;
    /***********************二分匹配模板**************************/
    const int MAXN=1000;
    int g[MAXN][MAXN];//编号是0~n-1的 
    int linker[MAXN];//记录匹配点i的匹配点是谁
    bool used[MAXN];
    map<string,int> m;
    map<int ,string> M;
    int len=3;
    int n;
    string bname,gname;
    bool dfs(int u)//回溯看能不能通过分手来进行匹配
    {
        int v;
        for(v=0;v<n*2;v++)
            if(g[u][v]&&!used[v])
            //如果有这条边,并且这条边没有用过
            {
                used[v]=true;
                if(linker[v]==-1||dfs(linker[v]))//如果这个点没有匹配过,并且能找到匹配点,那么就可以以这个边作为匹配点
                {
                    linker[v]=u;
                    return true;
                }    
            }  
        return false;  
    }    
    int hungary()//返回最大匹配数
    {
        int res=0;
        int u;
        memset(linker,-1,sizeof(linker));
        for(u=0;u<n*2;u++)
        {
            memset(used,0,sizeof(used));
            if(dfs(u))//如果这个点有匹配点 
                res++;
        } 
        return res;   
    }
    /***********************二分匹配模板**************************/
    void init(){
        len=2;
        memset(g,0,sizeof g);
    }
    int main(){
        // freopen("in.txt","r",stdin);
        while(scanf("%d",&n)!=EOF){
            init();
            for(int i=0;i<n;i++){
                cin>>bname;
                m[bname]=i;
                M[i]=bname;
                for(int j=0;j<n;j++){
                    cin>>gname;
                    if(m.find(gname)==m.end()){
                        m[gname]=++len;
                        M[len]=gname;
                    }
                    g[m[bname]][m[gname]]=1;
                }
            }
            // for(int i=0;i<n*2;i++){
                // cout<<M[i]<<" ";
            // }cout<<endl;
            
            for(int i=0;i<n;i++){
                cin>>gname;
                for(int j=0;j<n;j++){
                    cin>>bname;
                    g[m[gname]][m[bname]]=1;
                }
            }
            // for(int i=0;i<n*2;i++){
                // for(int j=0;j<n*2;j++){
                    // cout<<g[i][j]<<" ";
                // }cout<<endl;
            // }
            //cout<<hungary()<<endl;
            if(hungary()==n*2){
                for(int i=0;i<n;i++){
                    cout<<M[i]<<" "<<M[linker[i]]<<endl;
                }
            }else{
                puts("Impossible");
            }
        }
        return 0;
    }
  • 相关阅读:
    观察是快速成长的一个牛逼技能
    linux下使用lftp的小结(转)
    关于升级cocos2d-x网络库来支持ipv6、https,以及socket怎么支持ipv6
    cocos2dx支持arm64
    android studio 命令行编译cocos 3.15.1 安卓工程
    认识Android.mk和Application.mk
    mac os x下Android Studio3.0 配置本地 Gradle
    图片转成base64编码
    集成pbc
    6、SpringMVC:结果跳转方式 和 数据提交时的处理
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/6421682.html
Copyright © 2020-2023  润新知