• A Simple Game


    A Simple Game

    Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/65535 K (Java/Others)
    Total Submission(s): 75 Accepted Submission(s): 52
     
    Problem Description
    Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M1 stones, the 2nd pile has M2 stones, ... and the n-th pile contain Mn stones. Agrael and Animal take turns to move and in each move each of the players can take at most L1 stones from the 1st pile or take at most L2 stones from the 2nd pile or ... or take Ln stones from the n-th pile. The player who takes the last stone wins.

    After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

    The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
     
    Input
    The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers Mi and Li (20 ≥ Mi > 0, 20 ≥ Li > 0).
     
    Output
    Your program output one line per case, if Agrael can win the game print "Yes", else print "No".
     
    Sample Input
    2
    1
    5 4
    2
    1 1
    2 2
     
    Sample Output
    Yes
    No
     
    Author
    Agreal@TJU
     
    Source
    HDU 2007 Programming Contest - Final
     
    Recommend
    lcy
     
    /*
    题意:有m堆石子,每堆石子有Mi个,每次最多取Li个,谁取到最后一个谁输
    
    初步思路:对于一堆来说是八神博弈,对于整体来说是尼姆博弈
    */
    #include<bits/stdc++.h>
    using namespace std;
    int t,n,m,l;
    int res=0;
    int main(){
        // freopen("in.txt","r",stdin);
        scanf("%d",&t);
        while(t--){
            res=0;
            scanf("%d",&n);
            for(int i=0;i<n;i++){
                scanf("%d%d",&m,&l);
                res^=(m%(l+1));
            }
            printf(res?"No
    ":"Yes
    ");
        }
        return 0;
    }
  • 相关阅读:
    在Windows下生成SSH文件
    git常用命令总结
    小Q的歌单
    在vmware下安装Ubuntu16-04
    hexo-next博客中mathjax显示问题解决
    可乐复制问题
    hexo-next博客添加评论功能
    hexo-next博客添加在线联系功能
    tableau desktop
    tableau desktop
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/6376487.html
Copyright © 2020-2023  润新知