• 2015ACM/ICPC亚洲区沈阳站 Pagodas


    Pagodas

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 1282    Accepted Submission(s): 902


    Problem Description
    n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n . However, only two of them (labelled a and b , where 1abn ) withstood the test of time.

    Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk . Each pagoda can not be rebuilt twice.

    This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
     
    Input
    The first line contains an integer t (1t500) which is the number of test cases.
    For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b .
     
    Output
    For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
     
    Sample Input
    16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
     
    Sample Output
    Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
     
    Source
     
    Recommend
    wange2014   |   We have carefully selected several similar problems for you:  5960 5959 5958 5957 5956 
    /*
    等差序列,公差为gcd(a,b)
    */
    #include <bits/stdc++.h>
    using namespace std;
    int gcd(int a,int b)
    {
        return a%b?gcd(b,a%b):b;
    }
    int main()
    {
        //freopen("C:\Users\acer\Desktop\in.txt","r",stdin);
        int t,n,a,b;
        scanf("%d",&t);
        for(int Case=1;Case<=t;Case++)
        {
            scanf("%d%d%d",&n,&a,&b);
            int s=0;
            if(gcd(a,b)==1)
                s=n-2;
            else
                s=n/gcd(a,b);
            //cout<<s<<endl;
            printf("Case #%d: ",Case);
            if(!(s%2))
                puts("Iaka");
            else
                puts("Yuwgna");
        }
        return 0;
    }
  • 相关阅读:
    企业如何利用大数据?八个典型应用案例告诉你
    无焦点下获取条码枪返回值的Hook(再次改良版)
    combining-filters
    为Elasticsearch添加中文分词,对比分词器效果
    ElasticSearch NEST搜索
    How to write date range query in Nest ElasticSearch client?
    ElasticSearch关联查找
    form-inline+form-group 实现表单横排显示(Bootstrap)
    Elastic Search 5.x Nest Multiple Queries C#
    mysql 查看索引
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/6025484.html
Copyright © 2020-2023  润新知