• 2016 ACM/ICPC Asia Regional Dalian Online Football Games


    Football Games

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 5055    Accepted Submission(s): 904


    Problem Description
    A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced.
      
      At the first phase of the championships, teams are divided into M groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
      
      When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
     
    Input
    Multiple test cases, process till end of the input.
      
      For each case, the first line contains a positive integers M , which is the number of groups.
      The i -th of the next M lines begins with a positive integer Bi representing the number of teams in the i -th group, followed by Bi nonnegative integers representing the score of each team in this group.


    number of test cases <= 10
    M<= 100
    B[i]<= 20000
    score of each team <= 20000
     
    Output
    For each test case, output M lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
     
    Sample Input
    2 3 0 5 1 2 1 1
     
    Sample Output
    F T
     
    /*
    两个队踢足球,赢了2分输了0分平了各1分。
    给出你最后每个队的得分,问是否合法
    瞎搞过的,总得分为场次的2倍,并且得分奇数的个数一定是成对的
    */
    
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<string>
    #include<algorithm>
    #include<vector>
    #include<map>
    
    #define N 100010
    #define MAXN 100010
    
    using namespace std;
    int main()
    {
        //freopen("C:\Users\acer\Desktop\in.txt","r",stdin);
        long long m;
        long long n,s=0,a;
        while(scanf("%lld",&m)!=EOF)
        {
            while(m--)
            {
                s=0;
                bool f=0;
                long long ans=0;
                scanf("%lld",&n);
                for(int i=0;i<n;i++)
                {
                    scanf("%lld",&a);
                    if(a<0||a>2*(n-1)||a>(n*n-n))
                    {
                        f=1;
                        //cout<<a<<" 111"<<endl;
                    }
                    if(a%2)
                        ans++;
                    s+=a;
                }
                if(ans%2)
                    f=1;
                if(s!=n*n-n)
                {
                    f=1;
                    //cout<<s<<" "<<"222"<<endl;
                }    
                if(f)
                    puts("F");
                else
                    puts("T");
            }
        }
        return 0;
    }
  • 相关阅读:
    iframe和href中target属性的应用
    跨页面实现多选
    微软EPG老大发给员工的mail
    WebSerivce[连载]
    测试MSSQL保留字
    检正email的格式
    正则常用表达式
    企业库DAAB基本用法
    为什么覆写了Equals,还要覆写GetHashCode呢
    深入熟悉C# (待续)
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/5861179.html
Copyright © 2020-2023  润新知