• poj 1611-The Suspects(并查集)


                                                                                                                                   The Suspects
    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.  In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).  Once a member in a group is a suspect, all members in the group are suspects.  However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.  A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    题意:有N个人,分别编号0->N-1,已知有M个组,每组里面有若干人,一个人可分在多组中,0号是SARS感染者,如果某个人跟0号在一组,那么他有感染的嫌疑,还有如果某个人跟某个有感染嫌疑的人在一组,那么他也有感染嫌疑,问共有多少人有感染嫌疑。
    包括0自己。
    解析:并查集,对每一组,每个人都与第一个人并一次,最后查询有多少个人的根与0的根相同。

    代码如下:
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<set>
    #include<map>
    #include<queue>
    #include<vector>
    #include<iterator>
    #include<utility>
    #include<sstream>
    #include<iostream>
    #include<cmath>
    #include<stack>
    using namespace std;
    const int INF=1000000007;
    const double eps=0.00000001;
    int d[100005];
    int root(int a)
    {
        while(d[a]!=a)  a=d[a];
        return a;
    }
    void merg(int a,int b)
    {
        int ra=root(a);
        int rb=root(b);
        if(ra!=rb) d[ra]=rb;
    }
    int main()
    {
        int N,M;
        while(cin>>N>>M)
        {
            if(!N&&!M)  break;
            for(int i=0;i<N;i++)  d[i]=i;
            for(int i=1;i<=M;i++)
            {
                int group;
                scanf("%d",&group);
                int id,pre;
                for(int j=1;j<=group;j++)
                {
                    scanf("%d",&id);
                    if(j==1) pre=id;       //与第1个人合并
                    else  merg(pre,id);
                }
            }
            int ans=0;
            int t=root(0);    
            for(int i=0;i<N;i++) if(root(i)==t)  ans++;    //根要相等
            cout<<ans<<endl;
        }
        return 0;
    }
    
     
     
  • 相关阅读:
    Delphi以及三方控件的源代码规模
    InitInheritedComponent的执行过程
    poj 3897 Maze Stretching 二分+A*搜索
    一些窗口API函数,比如SetForegroundWindow,SwitchToThisWindow
    终于懂了:WM_PAINT 与 WM_ERASEBKGND(三种情况:用户操作,UpdateWindow,InvalidateRect产生的效果并不相同),并且用Delphi代码验证 good
    窗口绘制有关的消息整理 WM_PAINT, WM_NCPAINT, WM_ERASEBKGND
    WM_PAINT与WM_ERASEBKGND(用户操作和API这两种情况产生消息的顺序有所不同)
    关于WM_ERASEBKGND和WM_PAINT的深刻理解
    offsetHeight在OnLoad中为0的现象
    TWinControl.WMNCPaint对非客户的绘制
  • 原文地址:https://www.cnblogs.com/wust-ouyangli/p/4766455.html
Copyright © 2020-2023  润新知