• 【洛谷 1596】湖计数


    题目描述

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

    由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个NxM(1<=N<=100;1<=M<=100)网格图表示。每个网格中有水('W') 或是旱地('.')。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

    输入输出格式

    输入格式:

    Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    第1行:两个空格隔开的整数:N 和 M 第2行到第N+1行:每行M个字符,每个字符是'W'或'.',它们表示网格图中的一排。字符之间没有空格。

    输出格式:

    Line 1: The number of ponds in Farmer John's field.

    一行:水坑的数量

    输入输出样例

    输入样例#1: 复制
    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.
    
    输出样例#1: 复制
    3
    

    说明

    OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

    题解:DFS暴搜石锤

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    typedef long long ll;
    using namespace std;
    bool f[105][105];
    //char s[105][105];
    string s[105];
    int n,m,ans,xx,yy;
    int dx[18]={0,1,-1,0,0,1,1,-1,-1};
    int dy[18]={0,0,0,1,-1,1,-1,1,-1};
    void dfs(int x,int y){
        //if(x>n || x<1 || y>m || y<1) return;
        for(int i=1;i<=8;i++){
            xx=x+dx[i]; yy=y+dy[i];
            //if(f[xx][yy]==1) continue;
            if(s[xx][yy]=='W' && f[xx][yy]==0 &&
               xx<=n && xx>=1 && yy<=m && yy>=1) 
               { f[xx][yy]=1; dfs(xx,yy); } 
        }
    }
    int main(){
        scanf("%d %d
    ",&n,&m);
        for(int i=1;i<=n;i++)
            //for(int j=1;j<=m;j++)
                getline(cin,s[i]);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(s[i][j]=='W' && f[i][j]==0) {
                    ans++; f[i][j]=1; dfs(i,j);
                }
            }
        }
        cout<<ans;
        return 0;
    }
  • 相关阅读:
    2017年6月笔记
    2017年5月笔记
    2017年4月笔记
    转发:i p _ f o r w a r d函数
    IP分组
    IP协议首部结构介绍
    IP:网际协议
    sed工具使用
    正则表达式匹配
    TCP的半连接
  • 原文地址:https://www.cnblogs.com/wuhu-JJJ/p/11229275.html
Copyright © 2020-2023  润新知