• HDU2072 单词数


    单词数

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 40427    Accepted Submission(s): 9719


    Problem Description
    lily的好朋友xiaoou333近期非常空,他想了一件没有什么意义的事情。就是统计一篇文章里不同单词的总数。以下你的任务是帮助xiaoou333解决问题。
     

    Input
    有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。

     

    Output
    每组仅仅输出一个整数,其单独成行。该整数代表一篇文章里不同单词的总数。
     

    Sample Input
    you are my friend #
     

    Sample Output
    4
     

    Author
    Lily
     

    Source

    分析:恩,的确是的水题,直接暴力即可。

    可是,我发现了一个更牛逼的写法,一个超级牛逼的东西stream,这东西是真的屌爆了。不吹了。看代码。


    <span style="font-size:18px;">#include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <stack>
    #include <queue>
    #include <map>
    #include <set>
    #include <vector>
    #include <cmath>
    #include <algorithm>
    using namespace std;
    const double eps = 1e-6;
    const double pi = acos(-1.0);
    const int INF = 0x3f3f3f3f;
    const int MOD = 1000000007;
    #define ll long long
    #define CL(a,b) memset(a,b,sizeof(a))
    #define MAXN 100010
    #include <sstream>
    
    set<string> temp;
    string row,input;
    int main()
    {
        while(getline(cin, row)&&row!="#")///输入一行字符串能够用getline
        {
            temp.clear();
            stringstream str(row);
            while(str>>input)
                temp.insert(input);
            cout<<temp.size()<<endl;
        }
        return 0;
    }
    </span>


  • 相关阅读:
    2021昆明站K-Riichi!!(麻将)
    数据结构 Week 3 --- dsu on tree 和 点分治
    数据结构 Week 2 --- 平衡树
    数据结构 Week 1 --- 从线段树到主席树
    一些思维题(三)
    一些思维题(二)
    2021ICPC昆明站总结及补题
    2021ICPC昆明M题 非主席树做法
    2020ICPC昆明参赛
    记5.28leetcode简单题
  • 原文地址:https://www.cnblogs.com/wgwyanfs/p/7353493.html
Copyright © 2020-2023  润新知