• [ACM] POJ 2000 Gold Coins


    Gold Coins
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 20913   Accepted: 13098

    Description

    The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

    Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

    Input

    The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

    Output

    There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

    Sample Input

    10
    6
    7
    11
    15
    16
    100
    10000
    1000
    21
    22
    0
    

    Sample Output

    10 30
    6 14
    7 18
    11 35
    15 55
    16 61
    100 945
    10000 942820
    1000 29820
    21 91
    22 98
    

    Source

    解题思路:

    题意为 第一天获得1个硬币,后两天每天获得两个硬币,后三天每天获得三个硬币:如前6天每天获得的硬币数为 1 2 2 3 3 3

    问第n天一共获得多少硬币。思路为推断第n天包含几个连续的时间段(比方获得1硬币的一天 获得2硬币的两天 获得3硬币的三天)以及多出来不是一个完整的时间段的那几天,代码中用extra,并记录下多出来的这几天是第几个连续时间段。总金币= 完整时间段获得的+ 余下的天数获得的

    代码:

    #include <queue>
    #include <iostream>
    #include <string.h>
    #include <stack>
    #include <iomanip>
    #include <cmath>
    using namespace std;
    
    int cnt(int n)
    {
        int totalday=0;
        int get=0;
        int i;
        int extra;//不是一个完整的连续i天的那几天,比方1 2 2 3,extra则为1,获得3个硬币的那一天
        for(i=1;i<=n;i++)
        {
            totalday+=i;
            if(totalday>n)
            {
                extra=n-(totalday-i);
                break;
            }
            get+=i*i;
        }
        get+=extra*i;
        return get;
    }
    
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            cout<<n<<" "<<cnt(n)<<endl;
        }
        return 0;
    }


     

  • 相关阅读:
    Oracle 11g系列:函数与存储过程
    Oracle 11g系列:视图
    Oracle 11g系列:约束
    Oracle 11g系列:数据表对象
    Oracle 11g系列:数据库
    Oracle 11g系列:SQL Plus与PL/SQL
    Ext.util.TaskRunner定时执行任务
    MS SQL Server存储过程
    UML基础:用例图Use Case Diagram(1)
    UML基础系列:类图
  • 原文地址:https://www.cnblogs.com/wgwyanfs/p/7159261.html
Copyright © 2020-2023  润新知