• 杭电1005-Number Sequence


    问题描述

    A number sequence is defined as follows:f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.Given A, B, and n, you are to calculate the value of f(n).

    输入说明

    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

    输出说明

    For each test case, print the value of f(n) on a single line.

    输入样例

    1 1 3
    1 2 10
    0 0 0
    

    输出样例

    2
    5




    这道题之前用递归做的,结果runtimeError了,估计递归非常慢,想想会超出堆栈.后来百度,原来是个循环节的概念,因为有mod 7,所以f(n)取值是0-6,7个取值,而f(n)又由上头两个决定,因此有7*7=49种答案,因此在50以内必然出现循环,所以我们用数组模拟前49组数组,后面的数据只要mod (模除)循环节就可以了,对应的的数组里头取值,下面附上代码


    ------------------------------------下面附上AC代码-----------------------
    #include <iostream>
    using namespace std;
    int main()
    {
            int A,B;
            int N;
            int f[50];
            while(cin>>A>>B>>N)
            {
                    if(A==0&&B==0&&N==0)break;
                    int i;
                    f[1]=f[2]=1;
                    for(i=3;i!=50;++i)
                    {
                            f[i]=(A*f[i-1]+B*f[i-2])%7;
                            if(f[i]==1&&f[i-1]==1)break;
                    }
                    N=N%(i-2);//理解i-2,求的循环节N
                    if(N==0)cout<<f[(i-2)]<<endl;
                    else cout<<f[N]<<endl;
            }
            
            return 0;
    }

  • 相关阅读:
    SSD论文优秀句子
    A Case Study -- Performance Evaluation of a DRAM-Based Solid State Disk
    A Case for Flash Memory SSD in Enterprise Database Applications
    Understanding Manycore Scalability of File Systems
    slabs.c
    背包九讲
    redis async client 与自有框架集成
    同步git修改文件到远端服务器脚本
    服务发现:Zookeeper vs etcd vs Consul
    Linux 常用工具贴
  • 原文地址:https://www.cnblogs.com/wft1990/p/4312658.html
Copyright © 2020-2023  润新知