• 前缀匹配


    Problem B

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
    Total Submission(s) : 14   Accepted Submission(s) : 12
    Problem Description
    An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

    Examples: Assume an alphabet that has symbols {A, B, C, D}

    The following code is immediately decodable:
    A:01 B:10 C:0010 D:0000

    but this one is not:
    A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
     
    Input
    Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
     
    Output
    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
     
    Sample Input
    01 10 0010 0000 9 01 10 010 0000 9
     
    Sample Output
    Set 1 is immediately decodable Set 2 is not immediately decodable
     
     
    借鉴别人的代码:
    #include<cstdio> 
    #include<cstring> 
       
    char s[1000][100]; 
    int n; 
       
    inline bool check() 

        for (int i = 0; i < n - 1; i++) 
            for (int j = i + 1; j < n; j++) 
            { 
                bool flag = false; 
                int l1 = strlen(s[i]); 
                int l2 = strlen(s[j]); 
                for (int k = 0; k < l1 && k < l2; k++)///比strstr()要快一点 
                    if (s[i][k] != s[j][k]) 
                    { 
                        flag = true; 
                        break; 
                    } 
                if (!flag) return false; 
            } 
        return true; 

       
    int main(void) 

        int cas = 0; 
        while (gets(s[0])) 
        { 
            for (n = 1;; n++) 
            { 
                gets(s[n]); 
                if (s[n][0] == '9') 
                    break; 
            } 
            if (check()) printf("Set %d is immediately decodable ", ++cas); 
            else printf("Set %d is not immediately decodable ", ++cas); 
        } 
    }
     
    我的代码:

    不能输入数据
    #include<stdio.h>
    #include<string.h>
    #include<stdlib.h>
    #define MAX 20

    struct Trie{
     Trie *next[MAX];
     int v;
    };
    Trie *root;

    void CreatTrie(char * str){
     int len=strlen(str),i,j,id;
     Trie *p=root,*q;
     for(i=0;i<len;i++){
            id=str[i]-'0';
      if(p->next[id]==NULL){
       q=(Trie*)malloc(sizeof(Trie));
       q->v=1;
       for(j=0;j<len;j++){
        q->next[j]=NULL;    
       }
       p->next[id]=q;
       p=p->next[id];
      }
      else{
       p->next[id]->v++;
                p=p->next[id];
      }
     }
        p->v=-1;
    }

    int FindTrie(char *str){
     int len=strlen(str),i;
     Trie *p=root;
     for(i=0;i<len;i++){
        int id=str[i]-'0';
        p=p->next[id];
        if(p==NULL)
         return 0;
        if(p->v==-1)
         return 1;
        }
     return 1;
    }

    int main()
    {
     char a[20];
     int flag,k,i;
     for(i=0;i<MAX;i++)
      root->next[i]=NULL;
        while(gets(a)&&a[0]!='9'){
      CreatTrie(a);
    //  k++;
     }
     gets(a);
     if(FindTrie(a)) printf("YES ");
     else printf("NO ");
     return 0;
    }

     
  • 相关阅读:
    java的类加载机制
    tomcat jar包加载顺序
    重构 改善代码的既有设计
    ecilipse Javadoc文档注释
    常用HQL(Hibernate Query Language)查询
    在hibernate中查询单个对象的方法,get()、load()、
    hibernate -- HQL语句总结
    复杂的1秒--图解Google搜索技术
    作业-树状结构设计
    left join 和 left outer join 的区别
  • 原文地址:https://www.cnblogs.com/weiyikang/p/3883740.html
Copyright © 2020-2023  润新知