• HDOJ 2052 Picture


    Problem Description
    Give you the width and height of the rectangle,darw it.

    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.

    Sample Input
    3 2

    Sample Output
    +---+
    |   |
    |   |
    +---+

    别忘了每一个输出后面空一行

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int m = sc.nextInt();
                int n = sc.nextInt();
    
                for(int i=0;i<n+2;i++){
    
                    for(int j=0;j<m+2;j++){
                        if(i==0){
                            if(j==0||j==m+1){
                                System.out.print("+");
                            }else{
                                System.out.print("-");
                            }
                        }else if(i==n+1){
                            if(j==0||j==m+1){
                                System.out.print("+");
                            }else{
                                System.out.print("-");
                            }
                        }else {
                            if(j==0||j==m+1){
                                System.out.print("|");
                            }else{
                                System.out.print(" ");
                            }
                        }
                    }
                    System.out.println();
                }
                System.out.println();
    
            }
    
    
        }
    
    }
    
  • 相关阅读:
    简单手风琴特效、轮播
    MVC
    文字自动下拉隐藏显示
    jQuery基础 DOM操作
    JQuery基础
    SQL 中的常用函数及使用
    数据库中的T-sql语句 条件修改 高级查询
    2017-03-09 数据库的基本东西
    C#中的冒泡排序
    C#中的数组
  • 原文地址:https://www.cnblogs.com/webmen/p/5739438.html
Copyright © 2020-2023  润新知