• HDOJ 1196 Lowest Bit(二进制相关的简单题)


    Problem Description
    Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

    For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

    Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

    Input
    Each line of input contains only an integer A (1 <= A <= 100). A line containing “0” indicates the end of input, and this line is not a part of the input data.

    Output
    For each A in the input, output a line containing only its lowest bit.

    Sample Input
    26
    88
    0

    Sample Output
    2
    8

    输入一个十进制的数:然后转换为二进制,输出二进制的位数从后面到前面数的第一个1的时候的数的十进制。
    例如:26二进制是11010,所以从后面对前面数,第二位为1,所以取值为10,再转换成十进制,输出为2;

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n =sc.nextInt();
                if(n==0){
                    return ;
                }
                String str = Integer.toString(n, 2);
                //System.out.println(str);
                for(int i=str.length()-1;i>=0;i--){
                    if(str.charAt(i)=='1'){
                        System.out.println((int)Math.pow(2, str.length()-1-i));
                        break;
                    }
                }
            }
        }
    
    }
    
  • 相关阅读:
    三次握手四次挥手
    OSI七层模型和TCP/IP协议族
    CSS水平垂直居中方式
    CSS9种水平居中方式
    CSS8种垂直居中方式
    scss 初学笔记 二 混合宏
    scss 初学笔记 一 变量声明 默认的样式 嵌套
    面向对象的程序设计之对象
    underscore.js 源码阅读 一 整体结构
    underscore.js 源码阅读 准备
  • 原文地址:https://www.cnblogs.com/webmen/p/5739330.html
Copyright © 2020-2023  润新知