• HDOJ 1266 Reverse Number(数字反向输出题)


    Problem Description
    Welcome to 2006’4 computer college programming contest!

    Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one… Ha-Ha!

    Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
    1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
    2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
    3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.

    Input
    Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

    Output
    For each test case, you should output its reverse number, one case per line.

    Sample Input
    3
    12
    -12
    1200

    Sample Output
    21
    -21
    2100

    注意:前导0的情况!
    例:
    输入:
    3
    -0012560020
    00000
    00205
    输出为:
    -2006521
    0
    502

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while (t-- > 0) {
                String str = sc.next();
                int instr = Integer.parseInt(str);
                //System.out.println(instr);
                str = Integer.toString(instr);
    
                //System.out.println(str);
                if (str.charAt(0) == '-') {
                    System.out.print("-");
                    int k = 0;
                    boolean isOne=false;
    
                    //System.out.println(str.length()+"aaa");
    
                    for (int i = str.length() - 1; i >= 1; i--) {
                        //System.out.println("a:  "+str.charAt(i));
                        if(str.charAt(i)!='0'&&!isOne){
                            //System.out.println("++ "+str.charAt(i));
                            isOne=true;
                        }
    
                        if (isOne) {
                            System.out.print(str.charAt(i));
                            k++;
                        }
                    }
                    for (int i = 1; i < str.length() - k; i++) {
                        System.out.print(0);
                    }
                    System.out.println();
                } else {
                    int k = 0;
                    boolean isOne=false;
                    for (int i = str.length() - 1; i >= 0; i--) {
                        if(str.charAt(i)!='0'&&!isOne){
                            isOne=true;
                        }
    
                        if (isOne) {
                            System.out.print(str.charAt(i));
                            k++;
    
                        }
                    }
    
                    for (int i = 0; i < str.length() - k; i++) {
                        System.out.print(0);
                    }
                    System.out.println();
    
                }
    
            }
        }
    
    }
    
  • 相关阅读:
    【6】肿瘤胚系突变遗传分析及数据库使用
    【5】肿瘤DNA甲基化数据分析原理及流程
    【4】肿瘤转录组测序分析流程及相关软件
    【3】肿瘤基因组数据分析方法概述
    【2】肿瘤基因检测相关技术原理
    MySQL数据排序asc、desc
    python的数据类型
    Python minidom模块(DOM写入和解析XML)
    python基础----特性(property)、静态方法(staticmethod)、类方法(classmethod)、__str__的用法
    python os.path模块常用方法详解
  • 原文地址:https://www.cnblogs.com/webmen/p/5739321.html
Copyright © 2020-2023  润新知