• HDOJ(HDU) 1718 Rank(水题、、、)


    Problem Description
    Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.

    Input
    The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

    Output
    For each test case, output a line giving Jackson’s rank in the class.

    Sample Input
    20070101
    20070102 100
    20070101 33
    20070103 22
    20070106 33
    0 0

    Sample Output
    2

    其实就是统计按成绩排名,第一个输入的是学号,这个学号对应的成绩可以排第几!!!

    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner sc  =new Scanner(System.in);
            while(sc.hasNext()){
                long[] a = new long[1005];
                long[] b = new long[1005];
                long n = sc.nextLong();
                int k=0;
                int num=0;
                for(int i=0;;i++){
                    a[i]=sc.nextLong();
                    b[i]=sc.nextLong();
                    if(a[i]==0){
                        num=i;
                        break;
                    }
                    if(a[i]==n){
                        k=i;
                    }
                }
                int tm=1;
                for(int i=0;i<num;i++){
                    //System.out.println(a[i]);
                    if(b[i]>b[k]){
                        tm++;
                    }
                }
    
                System.out.println(tm);
    
            }
    
        }
    
    }
    
  • 相关阅读:
    ADO.NET 数据连接查询
    弹出消息对话框类
    C# 火星文转化 算法 dictionary 的使用案例
    微软官方的SqlHelper
    jsHelper
    【VC++积累】之六、MFC简要剖析
    C# 统计文章中字符的种类和个数 哈希表和字典的使用
    C# NetHelper
    C# XML操作类 XmlHelper
    【VS++积累】之七、黑客编程之匿名管道
  • 原文地址:https://www.cnblogs.com/webmen/p/5739278.html
Copyright © 2020-2023  润新知