• HDOJ(HDU) 2088 Box of Bricks(平均值)


    Problem Description
    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I’ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

    Input
    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.

    Output
    For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
    Output a blank line between each set.

    Sample Input
    6
    5 2 4 1 7 5
    0

    Sample Output
    5

    就是输入一组数字(代表砖),让它全部只能有平均值那么高,问移动的最少次数。(保证平均数是整数)
    一次只能移动一个。

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t=0;
            while(sc.hasNext()){
                int n =sc.nextInt();
                if(n==0){
                    break;
                }
                if(t==0){
                    t=1;
                }else{
                    System.out.println();
                }
                int a[] = new int[n];
                long sum=0;
                for(int i=0;i<n;i++){
                    a[i]=sc.nextInt();
                    sum+=a[i];
                }
                int avg = (int)sum/n;
                int num=0;
                for(int i=0;i<n;i++){
                    if(a[i]>avg){
                        num+=a[i]-avg;
                    }
                }
                System.out.println(num);
            }
        }
    }
    
  • 相关阅读:
    C# 多态类型
    字符集(Character set)
    CSS之backgroundposition 百分数形式
    javascript this对象 作用域链scope chain
    地图 查经纬度 算距离
    JavaScript 对象封装(完美版)
    iTextSharp 使用详解(转)
    社交网站 分享 +button
    COCOS2DX学习笔记(一) windows下cocos2dx的环境配置
    【首创】完美解决scrollview与menu的兼容问题
  • 原文地址:https://www.cnblogs.com/webmen/p/5739247.html
Copyright © 2020-2023  润新知