• HDOJ/HDU 1200 To and Fro(加密解密字符串)


    Problem Description
    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

    t o i o y
    h p k n n
    e l e a i
    r a h s g
    e c o n h
    s e m o t
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

    toioynnkpheleaigshareconhtomesnlewx

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

    Input
    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2… 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output
    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input
    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output
    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    水题。
    译码还原问题

    题目保证输入的数据一定是一个矩形的。

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n=sc.nextInt();
                if(n==0){
                    return;
                }
                String str=sc.next();
                String s[] = new String[str.length()/n];
                for(int i=0;i<str.length()/n;i++){
                    s[i]="";//不要忘记初始化
                    if(i%2==0){
                        for(int k=i*n;k<n+n*i;k++){
                            s[i]=s[i]+str.charAt(k);
                        }
                    }else{
                        for(int k=i*n;k<n+n*i;k++){
                            s[i]=str.charAt(k)+s[i];
                        }
                    }
                    //System.out.println(s[i]);
                }
    
                for(int i=0;i<n;i++){
                    for(int k=0;k<s.length;k++){
                        System.out.print(s[k].charAt(i));
                    }
                }
                System.out.println();
    
            }
    
        }
    
    }
    
  • 相关阅读:
    DG Standby之REDO传输服务
    .NET缓存初探[转]
    大型门户网站架构分析[转]
    jquery.each读取json数据
    WebService简单验证:SoapHeader
    DIV上中下布局高度自适应的研究[转]
    C#随机数生成(Mersenne Twister)及最佳种子获得方法[保存]
    Yahoo给出的34条网站加速方法[转]
    Asp.net中基于Forms验证的角色验证授权[转]
    获取SWF参数传值
  • 原文地址:https://www.cnblogs.com/webmen/p/5739151.html
Copyright © 2020-2023  润新知