• 【POJ】1840:Eqs【哈希表】


    Eqs
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 18299   Accepted: 8933

    Description

    Consider equations having the following form: 
    a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
    The coefficients are given integers from the interval [-50,50]. 
    It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

    Determine how many solutions satisfy the given equation. 

    Input

    The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

    Output

    The output will contain on the first line the number of the solutions for the given equation.

    Sample Input

    37 29 41 43 47

    Sample Output

    654

    Source

    Romania OI 2002

    Solution

    一开始以为是meet in the middle搜索.....

    然而完全没有那么复杂,甚至还可以用暴力map过??

    学习了一波hash表!

    其实和建边的邻接表很像,就是把某些值系在某个特定的节点上,一般是定一个不大不小的模数来确定位置。

    当然可能有重复,不过这就是hash表嘛!接在一起,查询就很接近$O(1)$了。

    主要程序:

    加入

    void add(int v) {
    	int x = v > 0 ? v : -v;
    	x = (x % mod + x / mod) % mod;
    	Edge[++stot] = Node(v, h[x]);
    	h[x] = stot;
    }
    

    查询

    int find(int v) {
    	int ans = 0;
    	int x = v > 0 ? v : -v;
    	x = (x % mod + x / mod) % mod;
    	for(int i = h[x]; i; i = Edge[i].nex)
    		if(Edge[i].v == v)	ans ++;
    	return ans;
    }
    

    很像邻接表吧~

    mod是自己定的,这里定的100007,加入或查询都是按固定的mod方案就能固定位置了

    #include<iostream>
    #include<cstdio>
    #define mod 1000007
    using namespace std;
    
    struct Node {
        int v, nex;
        Node() { }
        Node(int v, int nex) :
            v(v), nex(nex) { }
    } Edge[1000010];
    
    int stot, h[1000010];
    void add(int v) {
        int x = v > 0 ? v : -v;
        x = (x % mod + x / mod) % mod;
        Edge[++stot] = Node(v, h[x]);
        h[x] = stot;
    }
    
    int find(int v) {
        int ans = 0;
        int x = v > 0 ? v : -v;
        x = (x % mod + x / mod) % mod;
        for(int i = h[x]; i; i = Edge[i].nex)
            if(Edge[i].v == v)    ans ++;
        return ans;
    }
    
    int main() {
        int a1, a2, a3, a4, a5;
        scanf("%d%d%d%d%d", &a1, &a2, &a3, &a4, &a5);
        for(int x1 = -50; x1 <= 50; x1 ++) if(x1)
            for(int x2 = -50; x2 <= 50; x2 ++) if(x2) {
                int s = x1 * x1 * x1 * a1 + x2 * x2 * x2 * a2;
                add(s);
            }
        int ans = 0;
        for(int x3 = -50; x3 <= 50; x3 ++) if(x3)
            for(int x4 = -50; x4 <= 50; x4 ++) if(x4)
                for(int x5 = -50; x5 <= 50; x5 ++) if(x5) {
                    int s = x3 * x3 * x3 * a3 + x4 * x4 * x4 * a4 + x5 * x5 * x5 * a5;
                    ans += find(s);
                }
        printf("%d", ans);
        return 0;
    }
  • 相关阅读:
    C#随机数的使用
    英才评测 个人性格倾向 IT知识
    有点迷茫
    [转帖]2006年it人士必去的10个网站
    ASP.NET 中 Cookie 的基本知识
    Http请求方法
    Spherical Mercator
    Axure快速原型设计
    【转】Spring Insight 使用介绍
    DB2执行sql文件
  • 原文地址:https://www.cnblogs.com/wans-caesar-02111007/p/9838020.html
Copyright © 2020-2023  润新知