• 1100 Mars Numbers(20 分)


    People on Mars count their numbers with base 13:

    • Zero on Earth is called "tret" on Mars.
    • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
    • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

    For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

    Output Specification:

    For each number, print in a line the corresponding number in the other language.

    Sample Input:

    4
    29
    5
    elo nov
    tam
    

    Sample Output:

    hel mar
    may
    115
    13
    #include<iostream>
    #include<string>
    #include<map>
    using namespace std;
    string numTostr[170];
    map<string,int> strTonum;
    string unitDigit[13]={
        "tret", "jan", "feb","mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"
        };
    string tenDigit[13] = {
       "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"
    };
    
    void init(){
        for(int i = 0; i < 13; i++){
            strTonum[unitDigit[i]] = i;
            numTostr[i] = unitDigit[i];
            strTonum[tenDigit[i]] = i * 13;
            numTostr[i * 13] = tenDigit[i];
        }
        for(int i = 1; i < 13; i++){
            for(int j = 1; j < 13; j++){
                string str = tenDigit[i] + " " + unitDigit[j];
                numTostr[i * 13 + j] = str;
                strTonum[str] = i * 13 + j;
            }
        }
    }
    
    int main(){
        init();
        int n;
        scanf("%d%*c",&n);
        while(n--){
            string str;
            getline(cin,str);
            if(str[0] >= '0' && str[0] <= '9'){
                int num = 0;
                for(int i = 0 ; i < str.length(); i++){
                    num = num * 10 + (str[i] - '0');
                }
                cout << numTostr[num] << endl;
            }else{
                cout << strTonum[str] << endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    制作A4纸打印的网页像素大小设置(转)
    关于Vue.use()详解
    Vue的axios如何全局注册
    JS中的apply,call,bind深入理解
    JS异步编程 (2)
    JS异步编程 (1)
    彻底搞清楚javascript中的require、import和export(js模块加载规范的前世今生)
    IPv6地址分类及表示方法
    SublimeText3追踪函数工具CTags设置及使用
    转-编写CGI小结
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9571325.html
Copyright © 2020-2023  润新知