• 1050 String Subtraction (20)


    Given two strings S~1~ and S~2~, S = S~1~ - S~2~ is defined to be the remaining string after taking all the characters in S~2~ from S~1~. Your task is simply to calculate S~1~ - S~2~ for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S~1~ and S~2~, respectively. The string lengths of both strings are no more than 10^4^. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S~1~ - S~2~ in one line.

    Sample Input:

    They are students.
    aeiou

    Sample Output:

    Thy r stdnts.
    #include<iostream>
    #include<string>
    using namespace std;
    const int maxn = 10010;
    bool hashTable[256];
    string s1,s2;
    int main(){
        getline(cin,s1);
        getline(cin,s2);
        int len1 = s1.length(),len2 = s2.length();
        for(int i = 0 ; i < len2; i++){
            hashTable[s2[i]] = true;
        } 
        for(int i = 0; i < len1 ; i++){
            if(hashTable[s1[i]] == false){
                cout << s1[i];
            }
        }
        return 0;
    }
  • 相关阅读:
    Eclipse Save Action功能
    mysql优化
    数据库从RDS迁入自己服务器上问题记录
    阿里云centos6.5安装nginx
    阿里云mysql安装
    卸载wdcp面板命令
    高性能MYSQL读书笔记1
    DelayedQueue
    spring+atomikos 实现的分布式事务
    关闭Eclipse的控制台console自动跳出
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9520128.html
Copyright © 2020-2023  润新知