• 1008 Elevator (20)


    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41
    #include<cstdio>
    int main(){
        int n,k,f = 0, sum = 0;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&k);
            if(k > f){
                sum += (k-f)*6+5;
                f = k;
            }else{
                sum += (f-k)*4+5;
                f= k;
            }
        }
        printf("%d",sum);
        return 0;
    } 

     20190718

    #include<cstdio>
    
    int main()
    {
         int curr = 0;
        int k;
        int next;
        scanf("%d",&k);
        int sum = 0;
        for(int i = 0; i < k; i++)
        {
             scanf("%d",&next);
            if(next > curr)
            {
                 sum += (next - curr) * 6 + 5;    
            }    
            else
            {
                sum += (curr - next) * 4 + 5;
            }
            curr = next;
        }    
        printf("%d",sum);
        return 0;
    } 
  • 相关阅读:
    B树和B+树的区别
    宏(腾讯)
    数组作为函数参数传递时退化为指针(腾讯)
    求已知表达式的后缀形式(腾讯)
    JAVA笔记12-接口interface
    JAVA笔记11-Final关键字
    JAVA笔记10-抽象类
    JAVA笔记9-多态(动态绑定、池绑定)
    JAVA笔记8-对象转型casting
    JAVA笔记7-Object类之toString方法和equals方法
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9400576.html
Copyright © 2020-2023  润新知