• 1099 Build A Binary Search Tree (30)


    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    The left subtree of a node contains only nodes with keys less than the node's key.

    The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

    Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    

    Sample Output:

    58 25 82 11 38 67 45 73 42
    
     
    #include<cstdio>
    #include<queue>
    #include<algorithm>
    using namespace std;
    const int maxn = 110;
    struct Node{
        int data;
        int lchild,rchild;
    }node[maxn];
    int n,in[maxn],num = 0;
    
    void inOrder(int root){
        if(root == -1) return;
        inOrder(node[root].lchild);
        node[root].data = in[num++];
        inOrder(node[root].rchild);
    }
    
    void BFS(int root){
        queue<int> Q;
        Q.push(root);
        int num = 0;
        while(!Q.empty()){
            int now = Q.front();
            Q.pop();
            printf("%d",node[now].data);
            num++;
            if(num < n) printf(" ");
            if(node[now].lchild != -1) Q.push(node[now].lchild);
            if(node[now].rchild != -1) Q.push(node[now].rchild);
        }
    }
    
    int main(){
        int lchild,rchild;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d%d",&lchild,&rchild);
            node[i].lchild = lchild;
            node[i].rchild = rchild;
        }
        for(int i = 0; i < n; i++){
            scanf("%d",&in[i]);
        }
        sort(in,in+n);
        inOrder(0);
        BFS(0);
        return 0;
    } 
  • 相关阅读:
    动态规划训练之十
    数据结构训练之一
    图论训练之八
    数论训练之三
    动态规划训练之九
    动态规划训练之八
    动态规划训练之七
    杂题训练之三
    图论训练之七
    动态规划训练之六
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9306580.html
Copyright © 2020-2023  润新知